Dashboard Not Refreshing Cam Image

Seems there is no Ring tech support anymore,


Hey neighbors. Thank you for bringing this to our attention. I’ve reported this concern to the appropriate team, and rest assured, they are actively working on it. If you have any other questions, don’t hesitate to create a new topic and ask them. In the meantime, I’ll be marking this post as a solution so other neighbors know that we are working on this.

Same issue here. I have 3 wired floodlight pros, pro 2 doorbell, and a wired spotlight cam. One of the floodlights and the spotlight cam won’t update the live snapshots. I can connect for a live view, so no issues with wifi connectivity. The last updated preview image on those two cameras is from 2 days ago.

My dashboard seems to have switched from a 30 second to 10 minute update cycle – I changed NOTHING – why has this changed and what can I do to get more frequent updates back.

I have the same exact issue the Cam is not refreshing on the 4 cameras that I have actually there are a couple days old I’ve tried reset in the cache yesterday and done other troubleshoots , restarted the cameras the spotlight and the doorbell it’s definitely a issue with the firmware on the current version of the app please fix that.

UPDATE: the very next day the cameras photos on the app are updating every 60 Seconds as normal so I think logging in to the app community and having them send me the six digit code see what you have done something possibly because now the cameras are updating on the app main page while viewing the app but it appears that they won’t update unless the app is open for at least a minute and then they will start to update themselves I suppose this is normal?

Issue is not resolved. Dashboard feeds are still not updating or refreshing to current time lapse.

1 Like

Same issue for over a month. Have uninstalled and reinstalled and reset everything. Snapshot preview Images for all of my cams used to load instantly when I opened the app. Now it takes several minutes for snapshots preview to load on any of them, if they load at all.

1 Like

Hey neighbors. We have already forwarded your feedback to our teams as they work on getting this resolved. We do not have an update at this time. In the meantime, you can try the following steps as a workaround:

  • Activate a live view on the device, then return to see if the snapshot begins to update.
  • Clear cache and data for the Ring app in your phone settings. When doing this step, you will reset your Ring app permissions, which you will have to re-enable again. You will also have to log in to the Ring app again.

Again, we don’t have any additional updates or information to share right now. If any updates become available, we will share them in the relevant threads. For now, this reply will be marked as the solution to ensure new neighbors that come to this thread can easily locate this information. Thanks for your patience as our team works on getting this resolved.


I’m having the same issue. The dashboard doesn’t update the previews once I’ve done a live view. Only the doorbell seems to be updating for some reason.

I am having the same issue also also but only with the new Spotlight Cam Plus I installed about month ago. My door bell and other cameras work fine and update when I open the app. My issue seems to be only with the Spotlight Cam Plus that was just recently released.

It’s the app people. Dashboard only works on wifi to refresh. Cellular data won’t refresh. I even blamed the home wifi router and bought another only to run cameras. Again if on wifi it will auto preview and work. Back on cellular and it stuck.

1 Like

Same problem, for about 3 months now. It worked perfectly for the past 5 years and now the Dashboard just takes FOREVER to refresh. If I leave it sitting on the dashboard for 5-6 minutes, it’ll usually refresh most of my devices, but still not reliable. (even after checking live view of them)

Same issue as of 1/24/23

We had the same issue. I read all of these posts then we realized the new stick up cam was too far from our wifi router so we moved it to the other side of the garage. My go live view works now while only using mobile data and the preview now shows in the app when I open it. BIL just told us to buy the Ring wifi extender so we’ll be trying that too. Good luck!

Same issue starting end of Dec. '22. After a couple of weeks of the Dashboard camera views not updating, it worked for about a week, then, several days later, stopped working.
Even going to live view and returning to the Dashboard will not result in the latter updating, and the views can be 24 hours or older. Contacted support and, as they advised, deleted app data and cleared cache with no effect.
Reviewing this thread, it’s clear this has been an ongoing problem for a long time. Ring, when are you going to fix it? So far all I see is that you don’t have an update to share. Well, how about fixing the problem and sharing that?

1 Like

Same issue here. Dashboard camera views not updating as it should. It all started when it was updated to the latest app version (5.56.0) about a week or so ago. Now the Dashboard update it’s random from 15 seconds to 45 seconds to 3 minutes plus. Before the software update, it works perfectly and the Dashboard view is updated in few seconds once I open up the Ring app, now it’s just random. This is really important feature for me, please forward this to the correct team for a fix ASAP. This issue is happening on 2 iphone 12 running IOS 15.6.1

Things I have tried so far:
-Reboot both phones
-Reboot Wired floodlight cam
-Delete and re-install ring app on both phones
-Make sure settings are correct in the ring app
-Tried on 2 different Wifi connections as well as on Cellular connection
-Clear Ring cache

I really dont think the issue is with my phone or my network and I feel it will be pointless to call and spend time on the phone when they may just ask me to reboot this and that. Would one of the Tech here please forward this info to the appropriate team so they can look into it. Thank you.

1 Like

Same going on here. One of my cameras is indicating “Camera Previews not available” within the Dashboard view (on my PC and Mac). Within iOS, if I select the camera and go to Live View, and then back to the Dashboard view, the camera preview is then provided.
Clearly this is an issue Ring has recently introduced. The workaround is valid for iOS, but not for desktop browsers.
Come on, Ring, get this fixed!

1 Like

Stick up cam wired (3rd Generation) just does not update on ring dashboard. Period. Ring has been aware of this issue for over a year. Stick up cam wired (3rd Generation) act has if it is a Battery device even if it is plugged in. This is more than an issue and when u call them they act as if they have never heard of this issue and make you go through all sort of reset and reboot while they know that it is an issue with them. I mean come on Ring, get it together. It is false advertising if it just does not update every 30 seconds on the Dashboard just like the prior generation dont you think ?

1 Like

I am having this issue randomly happen with my ring cam stick up outside. It will randomly occur with different ring cam stick ups outside. Sometimes even on the ring floodlight cam, but very rarely on it. It has never happened on the ring doorbell pro 2. It often happens on the ring cam wired outside, but not always on the same one. I have several and sometimes one will work and not the other for the preview. However all the live previews on them work, but only sometimes will that cause the image preview to work in the dashboard view in chrome. I am also having the HEVC not supported error on one of the ring floodlight cams outside, but only one one of them. However, the other one works fine all the time for the live preview and does not get that error. Both of the ring floodlight cams are the same model and have the same firmware update, but only one gets the error. So it can not be the hardware or firmware, because it is the exact same on them both, but is only happening on one. It seems unlikely that it is the fireware or hardware with the image previews not working on the ring cam stickup models outside, as the ones that work or do not work, keep rotating and sometimes they all work and other times only one or both will not show the image preview. Thus this appears to be a server side issue with ring. All of these worked fine for months and only in the last few weeks have all of these problems started, and they are all only months old, they were not installed that long ago. This appears to be with the image previews not showing on the dashboard a issue now over a year old. What is confusing is I had no problems for the first few months and now only are these happening, so what ever was the problem a year ago does not seem it could be the problem now. As I had no problems for the first few months. I love the ring cameras and they have been so useful for months since I got them and most are still working ok, but this is a bug that makes it harder to use them. They all work fine on the app on my iphone, never have any issues. It is only on my computer in the browser that these issues are happening.

Is this issue still actively being investigated?
If so, any updates?