Couldn't Load your locations

We have a ring pro doorbell. Some days ago I added a ring indoor cam. Since that point every time I open the app on my mobile (huawei) it brings up a blue and white screen that states: - Connection Error - Couldn’t load your Locations - We’re having trouble loading your Location information. Please try again. (and then a RETRY button that when pressed goes no where). I tried the UK phone line and could not hear or perhaps understand the Ring operative who may have been outside the UK.

Can anyone please assist as the app and the doorbell worked fine until I added the cam?

Hey @Goldensyrup, could you try removing the Ring app from your phone, restarting your phone, and then reinstalling it? Once reinstall, please try to load the location and see your device. If you get this error message again, please attach a screenshot of this as it happens!

1 Like

Thank you Chelsea Ring. Your suggestion worked perfectly.

1 Like

I just cut my iphone off and back on. I signed back in to Ring and both my doorbell and outdoor cam came back up.

2 Likes

I’m getting this error now. My wifi is very strong, literally everything else works on it except for this. I tried reinstalling the app & when I put my verification code in to log back into my account I just get a something went wrong message. Help!!!

Hi, i got this issue today my ring only works from mobile data, and not working if connected to the wifi. Still got this messege Ring couldn’t load your location. I reinstalled the app, but could only login if am in mobile network, so i have no idea whats wrong with it. Could someone help please. Thanks

Hi @Myke! As you mentioned only being able to log in on a mobile network, does this error still show up if you are using mobile data? There may be some security settings enabled on the wifi network, or even a VPN that might be conflicting with connection. It looks like this may be an android phone, so please also check for any apps that might conflict with the Ring app. I hope this helps! :slight_smile:

I am facing similar issue as… ring app getting error about location. Follow the lead above re install and now getting somthing went wrong on login after entering code verification…

Hey neighbors! If the previous solutions suggest in this thread are not successful in resolving your concern, please give our support team a call at one of the numbers available here. They’ll be able to take a deeper look at this for you. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

Restarted iPhone, logged out of ring and logged back in…issue resolved.

1 Like

my ring app called not find location error message pop up and can not load the dashboard. no camera anymore. try to reinstall the ring app. first seconds. both camera came back. but after few minutes. it turns off line again and same error message pop up

Hi @lintom18. What type of phone are you using? Are you using a VPN? I would ensure that you have the Location permissions on and enabled for the Ring App. I hope this helps!

Hi all - I have the exact same problem. I am in the process of updating the ring app as it needed updating, but I have been getting the same couldn’t load locations error screen etc. The trouble is, the video doorbell is in the UK and I am abroad elsewhere. We recently got an electrician in to hard wire the doorbell in (he used a transformer so that we didn’t have to constantly charge the battery manually). Pretty much since then we have been getting the error location. So my question is, presumably when the electrician hard wired the doorbell in, he would have had to reconnect the set up of the device? he wouldn’t have been able to do this as we have the app abroad in a different time zone. So my other question is: if we delete and reinstall the app, will we have to reset up the device as we don’t have access to the QR code on the back of the doorbell unless we get someone to send us a photo of it?!! help please. L)

Hi @ukringvideo. In order to set the Doorbell up and connect it to wifi, you need to physically be with the Doorbell as you’ll need to access the setup button in order to put the Doorbell into setup mode. This means you wouldn’t be able to set the Doorbell up in the Ring App remotely. I hope that clears things up.