"Couldn't load location" on Ring App

I am running into an issue with both my Samsung phones (Z-fold 4 + Galaxy S22 Ultra) where I receive a “Connection Error: Couldn’t load your locations” as soon as I start the app. Interestingly I receive notifications just fine and can actually view the video when the camera(s) get triggered but outside of that the app is unusable. I have tried multiple things including:

  • Removing/Re-adding the app
  • Deleting cache/data
  • Using mobile data and NOT wifi.
  • Making sure VPN is disabled, including completing removing VPN apps.

The current issue of the Ring App on my Android phones is 3.55.1. The issue seemed to start after my latest update from the Play Store about 1.5 - 2 weeks back. Additionally, my iPad or my wife’s iPhone are NOT experiencing any issues.


Hi @akshtray. Those were excellent troubleshooting steps to try when an error message pops up in your Ring app. Rest assured that our team is investigating and working to resolve the issue as soon as possible. In the meantime, you can use Ring.com to access your recordings and other settings when logged into your account on a web browser on your phone or computer. I’ll mark this response as a solution so that other neighbors who see this post know we are aware of the issue and working to solve it. Also, once we have any updates regarding this concern, I will make sure to post those updates here. Thank you for your time and patience.

1 Like

We are experiencing the same exact issue. We have three Samsung Galaxy phones in the household and they are all having the same issue. I went through the same steps to try to resolve the problem but no luck. It seems to me that the app has a severe bug. I hope they fix it soon. We are paying for a service that is not very usable without the app.

1 Like

I’m experiencing the same thing. And i called my phone carrier, they said it must be an issue with ring. I’m paying for what… this is ridiculous.

1 Like

Since we are experiencing these issues, will we be refunded for the time the app is not working?

I had the same issue. I noticed I was connected to a network that had no internet connection. I changed network and it fixed the issue.

1 Like

I have exactly the same issue. My doorbell worked for 1 whole day before I got this.
I’m using whatever the current app version on google store is…3.64.0, and have a Galaxy S9+

My first Ring buy has not been a good one. I would never entrust Ring with my security system.

Hi neighbors. This concern was resolved; you should be able to open up the Ring app without getting the error message “couldn’t load location”. If you are still getting this error, please give our support team a call for further assistance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.