Constant blue light blinking

Constant blue light blinking

I have exactly the same problem. After working well for over two months my Ring Video Doorbell Pro lost connection to wifi and just had a constant blue blinking light, which filled the top half of the circle around the button.

From my reading of the support forums this says it is charging, but it has been doing this for two full days. I tried to reinstall, by resetting (holding button on RHS down for 15 seconds) then pressing the button to go into setup mode.

The white ring lights up for about half a second then goes straight back to blue blinking light.

Any ideas? I am hardwired.

3 Likes

Hey neighbors! Depending on the pattern of the blue light it could be powering up (circling) or it may be attempting to connect to your wifi (upward motion).

If the Pro is showing a charging indicator, this could mean the power being supplied is not sufficient for consistent power or there may be some resistance in wiring due to thinness or corrosion. Please check the power supply is rated for 16 - 24 VAC.

Wifi signal strength is another great variable to check to ensure the Pro has a reliable wifi connection. If you are using the 5 Ghz frequency, I recommend switching to the 2.4 Ghz to see if that improves functionality. Let me know how this goes. :slight_smile:

3 Likes

Thanks Marley, the blue blinking light is only a half circle going up, so wifi I think. Unusual because it worked perfectly for two months until it just went offline for two days, health check said signal strength and power were fine. I’m wondering given everything said in these forums that it may have been in the middle of an update when there was a wifi issue, as my spotlight camera at exactly the same time seemed to fail and started emitting a a strange noise for a while that was only fixed by pressing reset button on top of it. Its now working fine by the way and its further away from the wifi.

I have tried the : push side button on the video doorbell pro for 30 seconds : then do the setup procedure: about 10 times and it does not help. I note in some reddit forums there is a micro USB somewhere in the unit. Is there any way of using that to reset it? Or is there any other suggestions to resolve this.

It is only two months old.

Also: when I ring Ring support they DEMAND I send them a picture of the power plug it is plugged into and the transformer before they will help. I had this professionally installed at great expense and the power plug and transformer is in my roof, so I can’t get a picture unless I risk my life tramping through the roof which I have never done.

1 Like

I’m having the same problem with my pro.

Installed all was working correctly for a day then I deleted it by accident from the ring app. So I’ve tried the holding Side button for 30 seconds but it boots up flashes white for a second then the top half of the button flashes blue.

I’ve removed cover on the left side to access the USB port. And I’m currently charging it as I’ve read it could be battery. But still no difference. All I want is for it to go back to factory and have the circling white light to set up.

Sorry @Maisey_Mason to inform you this but I am having mine replaced under warranty. :cry:

I don’t know what this is with the Pro, and I’m glad you have tried the USB workaround as I thought that may have helped. But on my third call to Ring Support I finally got someone to get past the “send me a photo of your power plug and transformer” blockage.

They asked me to do all sorts of tests, then said a warranty replacement woud be sent. Unfortunately I will be away when it arrives, so no doorbell video monitoring while I am on holiday which is what I bought it for. :cry:

The installer has said in the last two years he has never had a problem with the non pro doorbells (Video doorbell and doorbell 2) and he installs two a week.

All I can say is if you have a Pro, and you get the blue light blinking half circle, then call support straight away and reference this thread.

3 Likes

Thanks @PK_senior having spoke with ring on live chat this afternoon. And as you said ask for pictures of the installation and power supply. They are sending me a warranty replacement. I’d only had 1 day use out of the original before the fault.

What i did find strange was I had to sign into ring website and add a credit card to the account for them to charge $1 before they would agree to order me a replacement.

@Maisey_Mason , They asked me for the credit card as well, luckily I already had one on there from my yearly subscription fee. Hopefully our replacement units work well, as from my experience the functionality is great. My wife actually had a long conversation with a Road Worker one day from her office in the city, when the road worker wanted us to shift cars as they were marking the road for new water mains.

I can only think from my experience in the world if IT, that the Pro’s have an issue with updating. I base this on the fact that it worked really well for two months, then it failed with the famous blue half circle blink, which shows a wifi issue. At exactly the same time my Spotlight Cam had an issue, which was solved by pressing the reset button and setting up again and its working as per normal. But if my Pro was in the middle of an update (and from reading a few threads here - that seems to happen a lot) and then I had a wifi issue, maybe its not robust enough to restart that update or recover from an interruption. And with your one day setup, maybe it was doing an initial update (??) and unrecoverably failed (??)

Or it may be something completely different. :smiley:

1 Like

Mine has done the exact same thing. It worked just fine for the first 12 hours after installation, then lost the wifi connection and went into charging mode. Which is what it has been stuck on ever since. It’s receiving a steady 21 volts from a brand new transformer and “pro power kit” it came with is properly installed. I went so far as to delete the device from the app and start over fresh. Now, with the doorbell being in a perpetual charging mode, I can’t even set it up again. Oddly enough, I can still ring my mechanical doorbell inside using it. I’m packing this Chinese-made mess back into the overpriced box it came in and return it for a refund. What pathetic waste of money.

1 Like

I had the same problem and after dealing with support and provide them with all type of pcitures they sent me a replacement device, which I was able to connect and wroeked for few hours and it happened the same.

I logged in to my account in ring and updated the framework of my chime and also connected the doorbel using the mini usb port to my computer, after 10 minutes it entered in setup mode.

You can try that, it is working for me now… but I had a hard time!!

1 Like

Sounds like you need to replace your doorbell. Not Ring, but the actual doorbell its connected to. That’s what fixed mine. Good luck!

“The installer has said in the last two years he has never had a problem with the non pro doorbells (Video doorbell and doorbell 2) and he installs two a week.”

An electrician has no electrical issues with battery-based doorbells? Color me unsurprised.

After we installed a replacement from Ring, there wasn’t a problem anymore. I believe they had sent us a second one when the first they sent still wasn’t working.

Yup mine too! Ring sucks and I will never purchase another ring device ever again.

2 Likes

I also had this same issue. I referenced this thread and after a few test to make sure it would not go into setup mode they issued a replacement!! My customer service experience was excellent…

2 Likes

We purchased a refurbished Ring Pro to replace our dead Two year old Pro. The Refurb wouldn’t go into setup. Ring replaced it and the second was pretty stubborn as well. We let it charge for 1/2 hour and it finally went into setup for us.

Be sure to let it charge on the system for at least an hour before you go around with support. They don’t seem to know this.

1 Like

Hey neighbors! We’ve updated our Help Center to include an article about the light patterns you might see on your Ring Pro. Before taking note of the light pattern on your Ring Pro, be sure to completely power it down for 3 full minutes, then power it back up. After 1 minute, you should be able to see one of the light patterns from the Help Center article so you can move forward with your troubleshooting. As always, if you need assistance at any point, our support team is ready to help! Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

I am having the same problem. I am about to talk to Ring support