Connecting to WiFi Pods

This week I moved ISP from BT to virgin and I have a hub 5 and some nice very super fast broadband. We live in quite a large bungalow and I already have taken delivery of one Virgin Wi-Fi network pod help get a better signal at the front of the house.

The problem is my ring doorbell 3 will not connect to the Wi-Fi pod, even though the pod is halfway between the front door and my router. The doorbell does however connect directly to the router and has an absolutely terrible signal ………so my issue is not that I cannot connect the ring doorbell to my new Wi-Fi, but rather than it insists on connecting to the weaker signal, despite having a better signal available from the pod. Other devices at the front of the house have connected to the pod.

I did not have this issue with BT, the ring doorbell connected quite happily to the BT mesh disc.

I have even brought a the doorbell inside the front door, and it is now only about 10 feet from the Wi-Fi pod and still not connecting. We have also performed a network reset on the doorbell and the new Wi-Fi connection was done with the Wi-Fi pod online.

I read in a separate thread that connecting my chime can sometimes help cajole the doorbell onto the strongest signal. I have done this and the Chime is quite happily sat on the Wi-Fi pod signal after connecting straight away. The doorbell is still on its terrible signal and won’t move.

The doorbell outside had a red RSSI of -77 and was also sometimes off-line. Inside the door it has a grey RSSI of -64. The chime (connected to the pod) has a green RSSI of -8.

Any ideas out there?


Hi @user27371. Does the pod utilize a 2.4GHz or 5GHz network? Try connecting to only a 2.4GHz, as this band is usually more resilient. Also, ensure that you are using the correct ports and protocols and take a look at your security settings on the pod.


The pod uses both 2.4 and 5 GHz. As I understand it this is creating a mesh network and whilst I can see which devices have connected to the pod and which to the router itself, I do not have any direct control over the pod. What I’m struggling with is why the ring doorbell 3 would connect quite happily to the main router and refuse to connect to the strong signal of a pod.

Hi @user27371. I’m not sure why the Doorbell will connect to one and not the other. I suggest reaching out to our support team so they can work with your directly and get this sorted out. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Hi, I was having same problem as you with regards Ring doorbell 3 not connecting to virgin WiFi pod even though they were right next to each other. I had an old Netgear extender that I connected directly through Ethernet from virgin hub 5 to Netgear and set Netgear as an access point which had a different WiFi name to virgin and connected ring doorbell to that network ie NetgearExt and now I have gone from Rssi of 70 to Rssi 38 and it stays connected continuously now. I unplugged Virgin WiFi pod and put it back in box.
I think if doorbell is too close to Virgin WiFi pod it won’t connect, not right I know but that seemed to be issue I was having.
So if you can use your old Bt router as an access point and it’s possible to run Ethernet cable from virgin hub 5 to bt router which is close to doorbell try that as it’s worked for me.
Hope this helps you or others out too.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.