Cisco Wireless ME and Ring Doorbells and Cameras connection issues

I recently upgraded my Cisco ME environment to, 3802 and 2702 APs. Apparently, when I did that my Ring Doorbell and Stick Camera both stopped associating to the network. I was unaware until a week ago I tried to view them and their battery had died, I didn’t receive the alert because they weren’t on the network. I have been trying for a couple of days to get them back on the WiFi but no matter what I did, they kept failing to connect to the internet. I finally got the doorbell to work today but only if I use Open authentication, no security. This is obviously a problem that I need to solve. I am using PSK with only the WPA 2 button turned on and they won’t connect.

Has anyone ran into this and how did you fix it?

Hi @ryankg21. Does your network automatically switch devices from 2.4 GHz to 5.0GHz? If it does, this could be the problem. Also, what is the RSSI for these devices? Try resetting them by pressing and holding the setup button for 20 seconds, then reconnect them to your wifi. This will prompt them to do a short update and they should remain online. Let me know if this works.

1 Like

Tom, no, i have both 2.4 and 5 GHZ radios on. The RSSI is really good where I am trying to connect them and where they will reside.

Hi @ryankg21. Thanks for getting back to me. For this concern, I suggest following up with our support team. They’ll be able to run some diagnostics on your Doorbell and determine what is going on. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

I am having the same issue with Curious if you figured out the issue and resolution? Thanks

1 Like

I has the same issue with my initial setup of my Ring 2020. I’m currently running software version I resolved the issue by disabling Basic Service Set Coloring for the 2.4Ghz network. Once disabled, My ring connected with no issues.

1 Like

I am experiencing a similar issue on Mobility Express version The Ring Stick Up won’t connect to ANY SSIDs (open and PSK) configured on ME, it will just say “Setup did not complete because your Wi-Fi password was entered incorrectly.”

My APs are not 802.11ax compatible, so I do not have the BSS Color setting mentioned above.

It is worth nothing that this camera has the same issue when trying to connect the camera to a mobile Wi-Fi dongle.

1 Like

Sorry to hear about this persisting, neighbors!

@RSpangler, Good call on altering those network settings.

@Hammo, thank you for trying out the settings and sharing other observations. It is odd to hear that an entirely different wifi access point is also not connecting your Ring device. If possible, try enabling a standard (encryption, SSID /PW, 2.4 Ghz, etc.) guest network on your main router and connecting to that. If available, try performing the Ring app setup steps, or reconnection steps, using another mobile device entirely. During the final home network connection steps of the setup process in the Ring App, there is an option to “add a hidden network”, in which choosing it will allow you to manually enter your network information to connect to.

Feel free to let us know how this goes! :slight_smile:

1 Like

Were you ever able to resolve this issue?

I am having the same issue with a new Stick Up Cam. I have a Pro doorbell, Spotlight Cam, and Indoor Cam that work perfectly fine, but I can’t get the Stickup Cam to work for the life of me.

Have tried a new very basic WLAN with 802.1r, etc. disabled… Still no luck. It appears to be associating and pulling an IP fine. I am at a loss.

Your issue seems similar to mine. I have a video doorbell 2 that associates and pulls an IP but I am unable to view the live stream from the ring app. Notifications work as well so I know it is connected to the ring servers. What’s even more puzzling is the the live stream works when linked to Alexa and using the Alexa app.

1 Like

Has anyone figured out the solution to this problem yet?

I also have a Cisco 3802i, running Mobility Express version Bought my first Ring device (Stick Up Cam Battery) and cannot get it to connect to Wifi. Tried creating a separate WLAN with no security, still won’t connect, tried turning off 802.1r, still didn’t work. just keep getting either the “Password is not correct” or “Could not connect to the internet, check your network settings” errors. It just keeps going through the same loops during setup in the Ring app.

Here is the odd thing - I also have a Cisco 3702i (borrowed from a friend for testing), running Autonomous image version 15.3.3-JPJ2, and the camera connects to it just fine. Quickly too. And it was configured using the same WPA2 settings as the 3802i. When it connected through the 3702i, the Stick Up Cam did get some type of software update when it came online, but it still won’t connect through the 3802i…