Charged battery now offline

I’ve had ring for about 6m and charge it once a month on average, charged it 2 days ago and now it just says offline & to reboot the router, I’ve done that but the ring still won’t connect to the WiFi. Any help gratefully received!

This sounds like a fault I’ve been having, call customer support NOW!!! DO NOT try and rectify it yourself.

I tried charging the battery and kind of got it working, so assumed the battery was at fault and made plans to replace the battery…when it finally became evident the doorbell was the issue, I called support who said my warranty had elapsed in the time between when the issue first happened and when I tried to rectify it by charging the battery multiple times…they’ve now refused to honour the warranty even though they’ve agreed that the unit fault started while under warranty.

Even if they tell you to just charge the battery, call them today just so they log the issue. They’ve told me that I essentially should have called and said “my doorbell battery isn’t charged” just for them to say “have you charged the battery? You need to charge the battery…”

Call them now, just to cover your back!