Certification Validation Failed - Redirecting to login - scrolling screen

Im having trouble accessing my ring app on my phone (samsung galaxy note 9). This is really a problem especially when my app chimes that someone is by my door and i cant access the app at all. Why hasnt RING addressed this problem immediately.

can someone from RING please email me as soon as possible


I am facing the same problem. Can you (@ring support) please help me out how to solve?

I tried already: restart phone, reconnect to internet, connect with other wifi netwerk.

I am having the same issue. I have restarted my phone, uninstalled and reinstalled the app. Still not working.

Im having the same problem and it’s happening on both my phone and my tablet. Something is very wrong. Thre customer service line keeps hanging up on me.

When I called customer service the automated vioce told me this was no longer a working number.

I am having this same problem and I just had mine installed today

And once it starts it won’t stop until I reboot. I had to uninstall the app. Reinstalling didn’t help either, it still goes crazy.

I just got through on the story line. They know the app is down and they’re working on it.

Same problem here. Only way to stop the cycle is to reboot device and not try to run the Ring App.

Uninstalling & reinstalling doesnt help either.

Hi neighbors, I’m sorry to hear you were unable to log into the Ring app. Rest assured, our team has investigated this and it looks like it should be resolved currently. You can always keep up to date on the status of Ring here: status.ring.com. Please let us know if there’s anything we can assist with in the meantime! :slight_smile: