Certificate validation failed! Redirecting to login

I copied and pasted the message below from another user’s post dated November 2019, as it explains my dilemma exactly.

My Ring App will not let me log in. I opened it just now and it displayed a pop-up message in black overlaying the app screen that has the “Create Account” and “Login” buttons. The message said “Certificate validation failed! Redirecting to login.” The screen kept flashing on and off and it was impossible to interact with it. What can I do to correct this issue?


I’m having the same issue. I uninstalled/reinstalled the app and after entering my log-in credentials, I receive a message that “an error occurred trying to perform operation.”

1 Like

Same problem here! Cant do nothing and im getting upset about to throw all to trash and go w another company!

1 Like

Same issue. Called support They said they were going through an update. That really doesn’t help if there is an emergency situation or a break in.


Same here crashed with the same error on multiple android devices. The just keeps flashing the screen. Rebooted the devices and it repeats the errors.

1 Like

I am having the same issue as others. Ring was just working fine a few minutes ago on my Android S8 and my husbands Android S10. Now we are both getting the Certification validation loop endlessly. I have rebooted the phones, I have deleted the cache, I have removed the app, rebooted the phone again and downloaded the app. Same thing happens. Doesnt matter if I am on the ATT network, Verizon or my home wifi. PLEASE HELP!!

Having the same issues. Cleared cache and deleted data and tried logging in again and still can’t get in.

The app on my phone keep saying Certificate Validation Failed! Redirect what should I do about this I pay alot for this Door ring 2 and I had it for a couple day somebody need to call me or email.

Hi neighbors, I’m sorry to hear you were unable to log into the Ring app. Rest assured, our team has investigated this and it looks like it should be resolved currently. You can always keep up to date on the status of Ring here: status.ring.com. Please let us know if there’s anything we can assist with in the meantime! :slight_smile:

I just discontinued my subscription until this is cleared up. Ring is useless to me for now. Please fix this!

I’ve been experiencing the same issue but with a slightly different twist. I can log in through the app OK and everything works find. But when I go to a McDonalds (two of them in different cities) and my phone automatically connects to their wi-fi, I get the same message (and flashing screen). Maybe McDonalds has a certificate problem. However, I can’t understand why the Ring app needs to log me out. You would think it would just suspend operation until it can open up a legitimate secure connection again.

 Hoping you can generate a fix for this.  It's a pain in the buttonia.