Certificate validation failed! Redirecting to login

I just starting having this issue as well. Galaxy S8, doesnt matter if its on WiFi or cell data. Was working just fine earlier today.

I have the exact same problem but it’s with every wifi network and also my mobile data is there a fix for this

I tried uninstalling and reinstalling as well but it didn’t work

I’m having the same issue as well. May have started with Ring forcing two-factor authentication. Still can’t get my Ring application to work. - Galaxy S9+

I’m having the same issue. Restarting the phone and reinstalling the app have had no effect yet

Same issue here. Somebody walked by, set off notification, then absolute nonsense from Ring app.

1 Like

My ring app was working fine all day, but now I’m seeing this issue, as well. Tried restarting phone, switching WiFi off, force stopped app…nothing works. This looks like a server issue to me.

1 Like

Same here. Just wanted to know when my kids were awake/moving upstairs and can’t even get onto the app. Super frustrating!!

I couldn’t even get to chat with anyone even though their help options state I can chat with someone. I got redirected to this community. It’s great to know I’m not alone but I would have liked to directly chat with someone about the issue.

1 Like

I’m experiencing this issue on a Pixel 3a XL / Android 10 / April 5 Security path level.

I set up a doorbell and chime earlier in the day without issue, but now am having the issue.

I’ve done multiple reboots and install/reinstall.

Happens on both WiFi and cell only data.

1 Like

https://youtu.be/WUQmjRl6Z_UI am now having the same issue.

Ring apparently doesn’t offer support? It redirects me here.

Anyone figure out a fix for this “certificate error”?


Having major issues. My phone has gone haywire

This just started happening on both mine and my wife’s phones. The danged app just pops up and starts flashing the error message. Something is happening with the ring system in general I think.


Seems this could be all on Rings end, everyone is having the same thing happening at the same time. All of us right now 04/15/20

1 Like

This is apparently a fresh issue. I am also on an S10+ and I’m noticing multiple posts with today’s date, so it has to be a new issue. Which stinks because i was tying to setup a new device

1 Like

Anyone have a resolve for this yet?

I just started having this issue. It was working fine up until recently. I have restarted my phone, I have turned wifi on and off. the screen just keeps flashing super quick. I have been able to hit “login” a couple times but can only put in my email address and then it glitches and gives me the error message and starts cycling through the screens.

I’m getting the same message and a series of pictures flashing from right to left with the login box disappearing before I can use it. I uninstalled and reinstalled the app and it’s doing the same thing. I also restarted the phone and that didn’t help either.

Just started in the last half hour, right?


Mine is doing the same thing! Nothing works too fix it!