Certificate validation failed! Redirecting to login

My Ring App will not let me log in. I opened it just now and it displayed a pop message in black overlaying the app screen that has the “Create Account” and “Login” buttons; the message said “Certificate validation failed! Redirecting to login”. However, first the screen kept flashing on and off and it was impossible to interact with it; I had to restart my phone to get it to stop. Then, when I tapped “Login” and entered my user name and password, I got the same “certificate validation failed” message and was put back to the login screen.

What is going on and how do I fix it?


Ok, it looks like my phone had a weird issue with its Internet connection, which I have now solved, and that lets me log in to the app and use it normally.

However, that raises another question: why couldn’t the app detect that the network connection was down and tell me that? A simple “the Ring app requires an Internet connection to work, please check your connection”, instead of (a) giving me a misleading message about certificate validation and kicking me back to the login screen, and (b) forcing me to restart my phone to stop the app screen flashing?


Hi @PeterDonis – I haven’t heard of any apps doing this. However, if I have my cell data turned off for a certain app, that will present a pop up when it can’t connect (I think this is more a phone setting vs app setting though) Can you please provide more detail or examples so I can share with the team?

1 Like

I am having the same issue however mine doesn’t reset after I restart my phone. I open the app and it just keep glitch flashing saying the same thing. Ugh so frustrating!


I just started having this issue and I figured out it has something to do with my phone being connected to my work’s wifi. If I turn off my cell’s wifi and use my data only then the ring app works fine. My phone (an S8) has issues switching back and forth from wifi to data so that may be part of it.


I have a problem at work as well as others who work there. We use a VPN to allow us to use the wifi and operate our Ring apps.


Has anyone received a response from Ring support on resolving this issue? I have restarted the Ring app and my phone twice. It still gives me the Certificate Validation Failure with login redirect message then keeps flashing between Ring app screens. For now I have disabled the app because it keeps happening. I need someone to contact me to get this resolved.


I am having the same issue on my Galaxy S10. Switching wifi off didn’t help. I use Ring app to enable/disable alarm. Having this issue is extremely frustrating.


Unfortunately having the same issue !


I am having the same issue. The screen goes off and on very quickly. I have no problems with my LTE nor wifi. It’s very frustrating. I reset my phone but it doesn’t help either.


I’m having the same issue. I am not on WiFi, my WiFi isn’t even turned on, however I did just leave work & I was using my wifi at work & Ring was working fine. I just left work, I stopped at a gas station, I got a motion detected alert & everything went Crazy glitching from the login screen & back over & over very fast, I can’t even click login fast enough & I tried multiple times. I cleared the ring app cache which did nothing. I’m gonna try to mess with it more once I get home. This bug needs to be fixed.


You aren’t the only one. I think there is a wider issue. I’m having the same issue suddenly from two different phones, whether I use a wifi or cellular connection.


Mine is doing this as well. If you fond anything out please post. I will do the same


I agree. I have also tried with disabling my wifi and still does not work. I am thinking about uninstalling the app and then reinstalling.


Our phones are also having this same error. It keeps cycling through the error and won’t display the login page long enough to be able to click it. Anyone hear back from support yet?


Having the exact same issue and so is my wife on her phone. App is bugging out.


I had this issue so severely that I have had to restart my phone TWICE. And I uninstalled and reinstalled the app and I had the exact same issue. I do not have any connection issues with my cell service or wifi at home.

I attempted to open my app after getting an alert. It never opened the app - it simply rotated between the ‘blue start-up’ screen that says Ring and the login screen. My phone showed a small text pop up that stated “Certificate validation failed! Redirecting to login” and from there became a never-ending cycle of flashing between the blue screen and login screen. It would NOT stop until I forced my phone to restart. This started just about 20 minutes ago.


Same problem on my Note 10 and Hubby’s LG

1 Like

This just happened to me too. Looks like it must be a soft issue on their end if the most recent comments are todays date.


I got the same issue since a hour ago. App reinstall, restart of phone and or other network doesnt help. Cant get in Ring app anymore!