Car cam videos not uploading to cloud

I am not able to download or share any video from the ring app. If I choose either the download or share option to get the 20 second clip I get the message “The video needs to be processed in our system first”. This does not matter if I am connected to Wi-Fi at my house or while driving on LTE. I am still under the trial LTE plan so there should be no reason I can’t down load video. Anyone else having this issue or know a fix?

1 Like

Hi @user38763. Drive events, which you can save 20-second segments of, are stored locally on the Car Cam. Make sure the Car Cam is powered and connected to either LTE or wifi when attempting to download a segment of a drive event. If this issue persists, please follow up with our support team at one of the numbers available here so they can take a closer look and gather any information they need to investigate.

I have same problem. Try to share a 20 second clip, get: “This video needs to be processed in our system first. We’ll notify you when your share link is ready.”

I’ve tried about ten times going back 48 hours. How many hours or days does this process take? I’ve yet to get any notification or see any clip appear anywhere in the Ring app.

I’ve also chosen download. It’s now been 36 hours. No sign of it either. Where is the download supposed to appear? Within the Ring app? I’ve tried share and download while sitting in my car with engine on powering the Ring Car Cam and watched video on my Ring app from that very moment from the Car Cam, so it is connected to either wi-fi or the AT&T radio network.

Can I presume this a known bug that will be fixed at some point?