Cant share my devices

I have invited my partner to share devices twice and seem to be stuck in a loop with his account. It shows invite has been sent at my end but not accepted.

Hi @user48198. Try completing removing your partner as a Shared User to clear up any issues with the invitation. Then send a new Shared User invitation to your partner. Make sure they’re using the email address associated with their Ring account as well.

Hello I am having the same problem and I have deleted the app reinstalled the app and removed her from the shared access but it is still not working.

Hi neighbors. In addition to the steps mentioned by Caitlyn, try the steps I have mentioned in this Community post. If you have tried these steps as well and are still having the same concern, give our support team a call at one of the numbers available here for further assitance. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.