Can't see live feed

Just got ring and im having issues with live view. I have good connection from my phone (34 ping, 151 down, 166 up) and have good connection to the actual video doorbell itself (RSSI-49)

Whenever I press “Live” it says “Activating Device” for 10-20 seconds then it says “failed to connect”

I have android and just in case I had someone with an iPhone, in a different state try it and did the same thing. I also tried Ring Rapid and the actual browser, ring.com. Same result

Thank you for covering all of these steps, @Zdouglass! You’ve pretty much covered all of the suggestions that I would make here, especially as you’ve tested this with multiple apps, methods, connections, and devices. As you mentioned just receiving this Video Doorbell, and live view never working, another variable worth checking is your network settings.

Here is our Help Center article about the ports and protocols used by Ring devices. Depending on the network equipment you are using, there may be some additional advanced settings that might help to adjust for video streaming and wifi. Please also ensure there is not a VPN enabled on any device being used.

If this concern persists, or if you need more assistance with the above steps, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

I just had the same issues and tried and checked everything too. Plus I uninstalled and reinstalled the App. I was able to receive Motion and Doorbell Notifications. As I was just about to give up I decided to press the Setup Button as I was putting the cover on. I got a Motion Notification and the Live View began to work. I don’t know exactly how or why but now seems to work. Maybe this will work for others.

1 Like