Can't resetup my ring doorbell

I have tried to reconnect my ring doorbell several times without success. I follow the procedures outlined in your setup instructions several times. Each time during the setup procedure the process stops with the white revolving circle stopping stops with the white arc on the left side of the circle. I have tried several times and the results are the same. The process stops with the white arc on the left side of the circle. The process will not go any further. What should I do?

Hi @evb. Since you have troubleshooted this to no avail, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to come back and let me know how this goes, as your response may help other neighbors! :slight_smile:

What was the outcome? I have the exact same issue, and device will not reset.

Can’t reach the support team as that has an error too on the app!