Can't get security screws off!

I can’t get either security screw to come off. The head is NOT stripped, I can get the Ring supplied tool in there, both screws spin with no problem, but just don’t come out - they just spin in place. I can’t get a good grip with pliers because the head of the screw is so thin. I need to change the wifi this connects to, and apparently you can only do this by accessing the orange button on the back of the unit, which I cannot get off. Beyond frustrated.

3 Likes

@dwiller1: Assuming you are correct and the tool fits securely into the screw heads and you can actually see the screws turning with the tool, but not backing out of the threads in the backplate, I can only guess that the screw or backplate threads are stripped for some reason. I’ve had mine out about 8-9 times to resync Ring doorbell with my wifi, so I’m familiar with what should happen.

My suggestion is to use an Exacto knife, or similar thin pointed razor blade, to try to gently wedge under the screw head as you turn the screw. Sometimes that causes the remaining threads to grab enough to back the screw out or reach the unstripped portion of the screw.

2 Likes

Thanks, tried with a screwdriver that day, but it was too thick. Will try a razor blade or my wife actually suggesed some thin wire that we can hopefully get under the head of the screw and one of us can apply downward pressure whilst the other one keeps unscrewing.

Ring support told me I could change the wifi without removing the unit, but when I followed their instructions…
"Here are the steps on how to connect your wi-fi connection without getting off your Ring device from the mounting location:

  • Tap on the icon or preview tile for the device we are setting up.
  • Select ‘Device Health’ from the available options.
  • In the Network section, tap on ‘Change Wi-Fi Network’ for online devices, ‘Reconnect to Wi-Fi’ for offline devices, or ‘Change Connection Type’. Only one of these options will be available.
  • A pop up appears advising you to be near the device and has your Wi-Fi password. Select ‘Continue’ to proceed."

Well after you click ‘continue’ the only options are to hit the orange button (can’t get the unit off to access the orange button) or remove the battery pack (this unit doesn’t have a battery pack, it’s hard wired.)

1 Like

Any luck with this? I’ve just tried to get it off to charge the battery and having the same issue?

I did get them off but it involved breaking the plastic at the bottom. I used a screwdriver to pry under the head of the screw and forced it out. It took a few days before i used enough force. I was able to do what I had to do and reconnected it with no security screws. I’m not worried about it getting stolen.

The exact knife method worked for me!!! Thanks. I did break off that screw tho, it was seized

No luck with knives/blades etc… however if you take a small thin screwdriver and twist in-between the backplate and ring device - it pops out of the holder really easily!!! Nothing broke so far (hopefully…) but this is pretty terrible quality…

4 Likes

Hello:

Been having trouble with my Doorbell camera for a while now. Had to change our wifi password which knocked our camera offline. In order to fix this, we have to remove the doorbell and push the orange button in the back, well, we have tried to remove the doorbell but the screws seem to be stripped. Any suggestions on how to accomplish this?

Thank you in advance.

How can both BOTH screws spin in place? I even broke the bit out of the screwdriver handle and put it on my drill-driver. Tried getting under the head with a razor blade and swiss army knife blade. Grabbing it with a flat ended pliers didn’t budge it. I need to charge it or it just becomes a dead ADT sign in the yard. The solar charger just isn’t working for me. Wanting my money back.

2 Likes

Thanks! Resorted to the brute force-off and it is recharging now. “Security screws” are screwed up!

Both fixing screws on doorbell unit are stripped and will not unscrew.

We were able to pry off the coverplate. Then, we were able to unscrew the security screw. The old coverplate is damaged. We installed another coverplate that came with the doorbell. We also had a spare security screw that came with the doorbell. Good luck, everyone! This was definitely a frustrating process!!

2 Likes

We are having the same issue. It started on one side and now it’s on both. Very frustrating as this is the second unit we have (the previous one just stopped working for no reason we could ascertain).

Is this a factory defect? Is the plastic shrinking and loosening its hold on the housing for the screws?

Very frustrating. We would try to fix it somehow, but are worried that they will say “you tampered with the unit and now you need a new one.”

1 Like

Hi @mdbringasgarcia! Try using needle nose pliers to grab and delicately pull on the screw while turning it to remove. A rubber band can also accomplish the same. If you feel like the screws are not going to come out without excessive force, Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

This is not the reason I’ll never buy or recommend Ring. It’s their lack of response in addressing the defective product. They told me to try tape, to try prying it, to strip it from the wall and access it from the back. No acknowledgement of “Hey, we messed up. We’ll fix the design and send you a new one.” This is all of our faults that the cheap plastic won’t hold its thread.

I ended up ripping it from the wall after weeks of support calls and trying different things with several friends offering to help. Now I’m looking into nest instead. I really loved the video quality and the mobile app, but one key mistake and bad customer service ruined it.

5 Likes

Did you ever get the screws out? Same problem here!

Having the same problem. Seeing the boards, I guess I’m not the only one. Ring’s failure to address issue is very frustrating. Definitely looking at Ring competitors as my Ring right now is just a decoration on my gate.

2 Likes

So for my unit, this was the issue. The insert that houses the security screw is spinning in the housing (see attached photo). To me, this is a manufacturer defect that they need to correct.

I’m going to hard wire my unit so that I don’t have to remove it for charging.

2 Likes

Same here. Screw is stripped. I’ll try the methods noted above, but it is quite frustrating that this is a common problem.

Me either. Screws just spinning. Unit needs charged. Ooh-tried rubber band, etc. nothing working. Any suggestions?