Can't connect to wifi, reset and white flashing won't stop

Video doorbell 2nd gen.
Device won’t connect to wifi. Have restarted, have changed routers, changed wifi addresses, literally sitting next to routers, etc. Tried to factory reset but the white light just keeps spinning. Clearly faulty device. What do I do?

Do you have “Location” turned on the cellphone that you are using to install the video doorbell and given the Ring app Location permission? After it’s connected, you can turn off Location or remove the permission for the Ring app.

You are trying to connect to 2.4 GHz network, correct?

Is it new? Can you return/exchange it from where you bought it?

Otherwise, call Ring Support. They will have you do trouble-shooting, and then if it’s under warranty or you have Ring Plus, they will replace.

Yes, yes and yes.

It’s only about 2-3 months old. Got through Amazon. I tried getting to Ring customer service but it just kept routing me to various articles that didn’t help. I guess I’ll have to try calling. 24 hours later and it’s still sitting here spinning white and occasionally making a chime noise.

Were you trying chat? I’ve never done that–only called. I don’t currently recall exactly the Ring Support routing options when you call. But I think that the system does try to get you to allow them to text you links to articles and stuff, which is not what you need…