Cant connect to new Frontier Wifi, ring stick gen3


Ring stick gen3 cant connect to new wifi (fronteir)
speed: Mbp 200dls/Mbp 190ul
-tried, new Bought router booster
-tried 2.4hz and 5hz
-resetting router
-resetting ring ring stick
-correct pw

  • moving ring stick directly to router
    -tried frontier “legacy mode”
    -lasted update/deleted and redownloaded
    Error message can not connect

lastly, reconnected to old wifi and its working. so its not the ring stick.

i have spotlight and doorbell ring that are working on the new wifi. stick ring will not

please help thanks

Hi @user45585. The Ring Stick Up Cam is only compatible with 2.4GHz wifi networks. If this new router is dual-band, I would suggest creating a guest network utilizing only the 2.4GHz network, then try connecting the Stick Up Cam to it. Additionally, ensure the ports and protocols used by Ring devices are open on your router.

If you’re still unable to connect the Stick Up Cam to your wifi network, please give our support team a call at one of the numbers available here for further assistance with advanced network settings. If you are outside of the US, please visit here to see how to contact support.