Can't connect to internet...tried everything i can find on the boards

Hi there, thanks for reading…I have a Ring Doorbell. recently replaced battery as charging every week was a pain. I go through install process, find the wifi network and after approx 20 seconds of the Ring device flashing while I’m told “Rome wasn’t built in a day”… the left side of button flashes and I’m told “There seems to be a problem with your internet connection”.

Some background

  1. I have google wifi running through Comcast XFi. I rebooted both. I created a new network specifically for the Ring. I prioritized network traffic to the Ring. I shut down the google network and just ran on the Xfi. I tried doing this sitting next to the Xfi router. no change

  2. I rebooted my phone, rebooted the Ring doorbell. No change

  3. I completely shut off all security on the Xfi. then rebooted and check to make sure it was shut off. repeated step 1. no change.

  4. confirmed Xfi and Google wifi running 2.4 and 5ghz

  5. my ssid does not have any weird characters.

  6. my network is pretty good…700mbs download and 30mbps upload. connection strength excellent through the house but i did these tests right next to wifi router in addition to normal spot on the front door.

Any suggestions welcome!

Hey @marksolly. You’ve done a lot of troubleshooting so I want to give you major props for doing so! One thing you could give a try, and the common thing we see, would be adjusting your ports and protocols on your router settings to allow the Ring device to reconnect. Please check out our Ring Help Center Article here, and feel free to get in touch with your ISP to make these changes if you cannot! Let me know if adjusting these helps it set up again. :slight_smile: