Can't connect Ring camera to wi-fi? Try this

Requirements:
A device that you can use as a hotspot. I recommend reading through first before just going through the steps.

Background
I upgraded my router recently. After I did, despite all of the Ring tech support and router tech support trying to help me get my cameras online, I couldn’t get past the 95% where the connection fails (2 stick ups, a doorbell, and floodlight). I know all of the tech support and resolutions steps by now like the back of my hand, and NONE worked. Of course, I could still connect to a hotspot on my phone.

Solution
What worked for me, and I’m hoping a few others with this problem can test, is utilizing my Wi-Fi hotspot as an avenue for connecting to my home router. If anybody having this problem could test this and report the results, I’m curious to see if it works for you. Steps are as follows and are for an iPhone, although I’m sure you could do something similar with Android, I just don’t have one to explain how to configure. I suggest trying this before you go to bed, because while it worked, it didn’t work right away.

Steps

  1. Make sure you can connect your wifi cam to your phone’s internet hotspot. Try setting up your camera with your hotspot and if it succeeds, move on to the other steps. If it can’t, this process has no chance of working for you (well it could, but that’s a different write up). If you have an iPhone for your hotspot, make sure you toggle the maximum compatibility option prior to trying to connect the camera.

  2. Make sure your home network has a 2.4 Ghz network broadcasting. Do not use smart connect features on your router. This is a feature that may be in your router that allows you to use one network name for both 2.4 and 5Ghz bands . You want to have your 2.4 and 5Ghz networks with separate SSIDs (Network names, as an example “Network 1” for 2.4 and “Network 2” for 5Ghz. I know ring says to create a guest network dedicated to the cameras but I didn’t find this necessary.

  3. Next take note of the exact spelling of your 2.4GHz network name and password and make sure there are no special characters in the password. Special characters are anything that aren’t numbers or letters. Now turn off your router. Not reboot, but pull the plug or turn off the switch if it has one.

  4. On the iPhone, go to Settings App → General → About, and then press on Name at the top. Change the name of your iPhone to your home router’s 2.4GHz network name.

  5. Hard Reset your camera (hold the reset button for 20-30 seconds and wait a minute after for it to initialize).

  6. Go back to the main page of the iPhone settings app and select Personal Hotspot. Change your password to the password of your home network 2.4GHz network. Toggle on Maximize Compatibility, and then toggle on Allow Others to Join at the top. Your hotspot should now be running and configured with the identical network name and password of your home router.

  7. Admittedly I used an iPad to setup my ring cameras and dedicated my iPhone to simply being the hotspot. I’d be curious to know if anyone can set one up with just the phone. I didn’t try.

  8. Set up the Ring camera as normal. It should connect to your hotspot. After it’s connected, and you can verify that you can use live view for the camera in the app with your hotspot, wait about another minute and then turn off your hotspot.

  9. Turn your router back on and let it boot up as normal. The Ring camera should be in the process of trying to reconnect to the hotspot but it isn’t there. Now your home router is available with the same network name and password.

  10. Wait and wait some more. I found that when I did this my doorbell and cameras connected within a couple of minutes to about 20, however, I could not see any video nor did many features work. After about 15 minutes for the doorbell I could use it as normal. After about 90 minutes the floodlight cam worked as it should. After about 3 hours both stick up cams joined the party.

Summary
I don’t know why this works for me. I don’t know why it takes so long after a successful connection for everything to work as it should, nor why it’s faster for one type of camera vs the other. If you are impatient like me, I’d try this an hour or so before bed so that you can let the cameras do whatever they do in the background to start to work by the time you wake up in the morning.

Request for Input
Please let me know if you tried this and if it worked for you. Please also let me know if you made any deviations to get it to work. I’m trying to create a tutorial thread to connect/reconnect cameras that fail on connecting to Wi-Fi after following Ring’s typical troubleshooting steps.

1 Like

My 2 new Ring cameras refused to finish the setup step the conventional way. I even upgraded my router from TP Link to Ubiquiti to try to resolve the issue. I followed your suggestion: the cameras worked perfectly on the hotspot. Then, I turned off the hotspot, started broadcasting the same SSID on my router, the cameras connected to the Wifi just fine, and the Ring app shows that they are checking in and updating their Device Health stats. However, neither liveview nor motion capture are working. Note that my 6 other Ring cameras work just fine.

I bought a UniFi router to get more control over network settings since TP Link waters down the GUI from a consumer perspective. I have troubleshooted this for many hours over the last few weeks. The last thing I have not yet tried is to run a tcpdump on the router.

TL;DR - I initially thought the hotspot suggestion would be the smoking gun needed to resolve this, but unfortunately it only addressed a symptom, not the cause.

If Ring reviews these forums, it would be helpful if future models allowed us to connect to the camera via IP address and view diagnostics from the cameras perspective to get a better understanding of the issues it experiences. If a simple webpage is not an option, perhaps default to downloading a log file of the last 30 minutes or something. Or, allow the Ring app to connect to the camera directly on the same network and use it as a terminal for diagnostic output.

An update to this. After I went to bed, I checked the app the next morning, and what do you know, they finally connected. I checked the timestamp and they both started checking in with snapshots after 3 hours. What happened after 3 hours to make them start working?

To recap, the router indicated that the cameras were on the WiFi, I could ping them from my laptop, and their Device Health updated in the app - the only issue I noticed was that liveview was not working, and motion capture was not occurring. But, after 3 hours, that was resolved. What is different in the new cameras: a different firmware? A different radio? I feel like we’re stepping into territory where “Reboot your modem, router, and the camera” is not a sufficient answer anymore. What is the QA process for changes to cameras? To make matters worse, I hooked these cameras up in place and plugged them into their solar panels only for them to say the panels are not connected. Of course troubleshooting 101 says to reboot the camera… I rebooted the cameras, and am now waiting for them to start working again with liveview and motion capture… This experience is really making me question if I would recommend Ring anymore.

Hi @tobiewolfen. That is odd behavior for your Cameras to do. If the basic troubleshooting steps do not help, the next best course of action is to reach out to our support team for further assistance. They will be able to take a look into this in more depth than we can here in the Community. Give our support team a call at one of the numbers available here.

I also had trouble connecting my spotlight cam + to a Verizon hotspot. The camera would connect to my android phone hotspot, and my phone would connect to the Verizon hotspot (orbic speed), but the cam wouldn’t connect to the orbic. I used the method above to change my phone hotspot name and password to mimic that of the orbic. Following the directions above did not work however. What did work was setting up the cam with the android hotspot as the Wi-Fi (orbic off), then turning on the orbic while my phone hotspot was still on, then turning the phone hotspot off. Victory after two days of trying and phone calls to Ring and Verizon.

1 Like

I have the same issue with my Ring products connecting to an Orbic from Verizon.

It will occaisionally connect to it, but it is at a camp and if the power goes out it will not reconnect automatically or even manually when I return. I have not had it running for over a month now.

The Ring Staff that said call support… I have called many times without any assistance. The info in this community is way more than I got from them reading a troubleshooting manual for sure. They say that mobile is not strong enough, though I can connect the ring device to any phone without issue. and the Orbic can handle 5 TV’s at once without a problem. Also when I can get it to connect, it runs flawlessly.

It seems to be a setting in the firewall or other setting on the Orbic that is an issue, but I have not been able to find it.

I am going to try this trick and see if it works. Fingers crossed.