Cant complete setup "Hmm, something went wrong"

Ring Video Doorbell 2 Model 5UM5E5

The worst setup experience of my life! This ought to be a total doddle, and it isn’t.

  1. Creating the Ring account and logging on required many attempts with many demands for verification codes, and many demands that I verify my email address.
    Got past this eventually (how?).

  2. Now to set up my Video doorbell 2…
    “Add a Ring product”
    “Doorbells”
    “Scan the code” - it wont scan, so I press “SETUP WITHOUT SCANNING”
    “Ring video doorbell 2”
    Where to set it up…my address, OK.
    Give it a name “Front Door”
    No removable battery
    Press the orange button.
    Spinning white light on the front of the doorbell.
    “Hmm, something went wrong” “Please start the setup process again.”
    Go back to step 2. above.
    Repeat this process for ever…?

The device is stuck in setup mode with the spinning white light.

I have spent 2 hours on this so far. How much longer?

This exact issue has been a problem trying to get my mother’s ring devices connected.

Would be great if Ring Support “chimed” in on this. FYI: My mother’s phone is older and not using the most current version of Android and cannot be upgraded to the newest version of Android. It is Galaxy S6 with Android 7.

Hi @missouriman. It sounds like you might be getting the models of our Doorbells mixed up. We have our new Ring Video Doorbell Generation 2 and our Ring Video Doorbell 2. They sound very similar, but are completely different. The Ring Video Doorbell Generation 2 does not have a removable battery. If you are selecting the wrong Doorbell in the Ring app, you will most likely get this error every time. Try selecting the Ring Video Doorbell Generation 2 and see if that works.

@MoonGear. If you are using a phone that has an outdated Ring App, you will also get the message “Something went wrong”. The Ring App is designed to be ran it its most current version and trying to get full function from an outdated Ring app will be problematic.

If you are still having concerns, Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Thanks for your reply, Tom_Ring.

Your products display the same problem that very many manufactured products show: the customer cannot identify the product because the product does not show the exact model in a clear manner in a prominent place.

So, when I as the customer try to get downloads, or any kind of assistance from the manufacturer, I cannot see My Product from the list displayed on the manufacturers web site.

This is especially frustrating in the case of this particular product for the following reasons:

  1. My 4 year old, low-spec smartphone simply refuses to register the QR code, because it’s far too small. So I can’t discover the product that way.

  2. Confusing product designations. You say there are two products that I might have: “Ring Video Doorbell Generation 2” and “Ring Video Doorbell 2”, and that they are completely different. So why are these very different products given designations that sound almost exactly the same? It looks like you have designed customer confusion right into the product!

  3. Your app on my smartphone did connect to the Ring doorbell, because the doorbell said it did, before your app said there was a problem. For goodness sake, if YOUR app can communicate with YOUR Video Doorbell, it should be able to idently YOUR model number? But it can’t. So, what chance do I have of identifying the model?

  4. I quoted the product ID I thought might be useful to you at the very start of my message. Look, it says “Ring Video Doorbell 2 Model 5UM5E5”. But even you can’t tell me from this information what product I have. Again, what chance do I have?

Please guys at Ring, get your act together:

* CLEAR model designations.
* NON CONFUSING model designations.
* GET YOUR APP to recognise the model, don’t expect the customer to spend 2 hours mucking about trying to solve YOUR problems.

This kind of model-confusion nonsense happens far too many times with far too many manufacturers.

I have returned the product and received a full refund, so I am now an ex-Ring customer, and likely to remain so for a very long time.

3 Likes

Had the same issue. What worked for me was to shut down the circuit breaker and leave it tripped for ~5 minutes.
Reset the breaker and give it another 5 mins to sync again. The setup went through like a breeze. Hope this helps.

1 Like

I had similar problem. Tracked it down to my Android phone switching networks. Turned off Smart Network switch and Data on my mobile and I could then run through the setup successfully.

1 Like

Hey neighbors! Thank you for checking back in and letting us know what worked for you! This will surely help out if someone comes across a similar issue. :smiley:

I’m having this issue too! I also tried what above said to try. But it’s still doing the same thing! I’ve been messing with this thing for a week and I can’t get it set up!! I have the ring video doorbell 2nd gen and im trying to set up via the ring app on my Galaxy Note10+ please someone help!!

Been having the same problem with my Galaxy S20+ & Video Doorbell (Generation 2).

My partner has since managed to get it set up first time on her Huawei P30, however got the Chime through today and once again I can’t set it up, just keep being told to retry the setup process from the start.
I have tried disabling my mobile data during the process/ensuring autonetwork switch is disabled etc to no avail…

I had this problem. It works when I scan the QR code on the actual doorbell, rather than the MAC barcode on the box.

What do you mean by ‘circuit breaker’ ?

We had to log in to tell you what worked for us! We had the exactly same problem as described by OP. We tried both Android and on IPhone and was still stuck on a never ending loop of trying to connect to WIFI.

Out of desperation, my husband plugged the ring doorbell to the USB charge cable while we waited for the technical support to call us back. Once plugged in, the Ring doorbell prompt us to try connecting again and it worked this time! We did nothing differently other than plug it in. We still don’t know why. But hope this helps!

1 Like

I have exact same issue. I am a software tester by trade. Two phones used iPhone and android on. The latest os and app.

Same something went wrong error. Rebooted phones, router door bell. Some error codes would be useful.

As for user experience that’s very poor.

Ps I’m a device test specialist with 15 years of device testing in. Cpe, routers, iptv stb.

Please you need to do better at QA

1 Like