Cannot use two-way talk on Ring.com live view, mic icon is greyed out

The mobile app is nice and works well. But when I am home or at work I log into Ring.com via Chrome. I can do everything with the doorbell and flood cam EXCEPT 2 way talk as the mic icon is greyed out. Speakers, lights, siren all work but not the mic. And yes, I have a function mic on my PC. Any ideas?

In Chrome’s settings, have you the Mic permission turned on for Ring.com?

1 Like

Well now I feel silly. I have never had to enable that for any other web app. Ring was blocked. THANKS!!

Don’t! :slight_smile: I didn’t know about that setting myself until I read it in these forums!
Glad it’s working now.

1 Like