Cannot login on App

Hi all, I cannot login to the app on my phone, spoken to ring for 30 minutes who told me I need to speak to my network provider or there is a VPN setup in the background that I don’t know about.
My phone says there is no VPN, I have turned phone off and on again, deleted and reinstalled the app.
I am at my wits end as I don’t understand why it’s not working, has anyone overcome this please?

Hi @user70463. Let’s start with some important information that we are missing. What type of phone is this and what version the Ring app is installed? Are you on cellular data or WiFi. Can you login on Ring.com?

I am having the same problem. I have an iPhone 13 with 17.1.2 iOS. I deleted app 5 times. Powered down my phone. Shut off cellular. Tried with wifi. Shut off wifi and tried with cellular. Changed password to your recommended password. I have no VPN attachments.

Ring app version 5.67.0

I can login on my computer and other devices.

Hi neighbors. If you’re having issues logging in on the Ring app, please ensure your Ring app and phone’s software are fully updated. Verify that no VPNs are active on your phone, and check that you are using the correct account email and password. Check your phone’s browser settings to ensure cookies are not blocked, and that Javascript is enabled.

If this issue persists, or you’re seeing an error message that states “Sign in failed. Try restarting this app or check for an update in your mobile app store. (reference: xxxxxx)”, please follow up with our support team to investigate and troubleshoot further.

1 Like

I am also could not login to the Ring App and seeing an error message that states “Sign in failed. Try restarting this app or check for an update in your mobile app store. (reference: xxxxxx)” after upgrading the new iPhone 15 Pro Max. The same password still works fine with my iPad and the Ring website. I deleted the app, restarted my iphone and re-installed the Ring app many times, but the login still failed with the same above error message. I followed up with the Ring support team as suggested and talked to Banele. He said this is a trending issue (TECH-3206), so Ring has been investigating for the fix, he could not help right now. Please send me a notification when the fix is complete. Thank you.

Same exact issue here! Deleted the app, reinstalled, restarted the phone. I don’t have a VPN, and I can sign in through a web browser on my phone I just can’t sign into the app. My wife can access it fine on her phone but I’m the account owner and can’t sign into the app no matter what I do.

I even added a different email address as an added user through the homepage, verified the account and tried to sign into the app - same error message pops up.

Customers are completely locked out of our security systems and we keep getting this copy-and-pasted crap about VPNs.

This is a Ring bug - NOT a user issue. Ring, fix this problem!

iPhone 12 Pro running iOS 17.2.1

1 Like

I can login on the website and here so it’s not my details. I don’t have a vpn turned on I have deleted and reinstalled the app. My phone doesn’t need an update and neither do apps. When attempting to sign in message appears;
sign in failed. Try restarting the app or check for an update in your mobile app Store. (Reference cd7fe4).

The reference changes with ever attempt.

I found a fix for me…
The app uses safari to login. So there were Adblocks/ security settings that were impeding communication. I don’t know why because I could still login just with a search engine separately. Possibly it was (prevent cross site tracking).

If you want to try this (if you have an iPhone).
Open settings, scroll to safari, under privacy and security there is a slider called prevent cross site tracking. It might be locked.
If it is locked scroll to the bottom and open advanced. Something here will unlock the slider possibly block all cookies.

Once I had disabled all the cookies/ad blocks and allowed cross site tracking I could sign in on the app. I could the switch all the settings back.

4 Likes

Furthermore I just wanted to say that customer support could not help and the website is not optimised for mobiles properly. Also the support chat closes itself every 15 seconds or so on both mobile and desktop, safari and chrome making it almost impossible to use.

I have exactly the same problem - and have tried EVERYTHING - several times. I can access on my iPad - but not on my phone

Thank you so much for your instructions. Actually this worked perfectly. After turning off “ prevent cross-site Tracking “ off my I am able to log back in on my phone. I tried for more than month but couldn’t do. Finally this problem is solved. Thank you User74550

1 Like

I am having the exact same problem. It not allowing me to log in. I am about ready to throw these things in the trash

Had the same issue and your fix worked perfectly!! Thank You!!

1 Like

THANK YOU. this worked FINALLY

1 Like

Hey 74550 - You da man! or Woman! That worked!

1 Like

THIS IS THE ANSWER!

I have been waiting since DECEMBER 22ND (today is February 10th) for the ding dongs at Ring to figure this out. I’ve had my issue “escalated.” I’ve spent an absurd amount of time talking to tech support who say they have launched an “investigation” and will “email me when there’s resolution.”

ALMOST TWO MONTHS of not being able to use Ring on my phone and NOBODY at Ring could figure this out. I called for updates and they supposedly escalated my issue yet AGAIN and were going to get back to me.

TWO MONTHS! TWO MONTHS of having a device and paying for a service I can’t use. AWFUL tech support. THANK YOU TO THIS USER FOR FIGURING OUT WHAT RING’S ENGINEERS COULD NOT.