Cannot Log Into Ring Account online

I have installed Ring devices and the ring app. I can log into the ring app but cannot successfully log into the ring account online. The sign-in page just sits there.

Have tried on multiple devices.

Problem is that because the online log-in doesn’t work I cannot completing invite to my wife to be able to access & use the devices.

Have called Ring help desk, they were great but did not see any problem with their website sign-in.

Is anyone else seeing this issue? I am in Australia.

Hi @Mudd2001! If you are able to get in on the Ring app, the website should certainly allow access as well. Although you’ve tried on multiple devices, please also attempt this using a different browser or connection type (wifi only vs cell data only). Feel free to let us know how this goes! :slight_smile:

I was able to log into the accounts via mobile data, but not WiFi. Tried multiple devices and multiple browsers on WiFi simply does not allow sign-in.

That is odd to hear! Glad you were able to get in, but it sounds like something may need looked at within your network. I recommend checking in with our support team, with these new findings, to see what they can do. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know how this goes! :slight_smile:

continue to get the spinning icon of death that never resolves whenever i try and access account section.

Ring on iPad was working fine on iPad but now when clicking on app icon

I get log in prompt

Could access ring on iPad a few days ago but not today.

Also cannot log in through app

When clicking on Ring app I get create account or log in but cannot go anywhere from that point keyboard is only partially displayed.

Hi @Dkcamaro68ss. Try uninstalling the Ring app, rebooting your iPad, then reinstalling the Ring app. This will prompt you to login and your keypad should fully appear. If your need more support, click on the link in the previous post for information on how to contact our support team.