Cannot delete device from group, and then delete group

My floodlight cam lights are in a light group, which I want to delete (as it used ot be, I never used to have them ina. group).

So I go to ‘Delete group’ and I see this:

This group still contains devices. Please move all devices to another group before deleting.

That’s fine, so I go to Edit Group, and then uncheck the light. It asks me Where are you moving this device? I select Remove from group. And then press Save. Says Group updates saved, and returns to the previous screen.

But nothing has changed, the group is still there, if I go to edit the group again, the device is checked back ON.

So I’m stuck in a cycle bug where I cannot remove my device froma group, so I can delete the group.

Why isn’t this doing what it’s supposed to do?

Further more, when are Ring going to actually put their staff back on support chat? Surely they’re not allowed to completely remove all their support staff when they don’t need to? It makes no sense why there’s no chat agents anymore. They can work from home.

4 Likes

I’m also having this issue. I’m attempting to share my Floodlight camera and can not do so because it is grouped.

Please advise. Ring Support this is a bug.

3 Likes

Hey neighbors! If you are unable to remove the old light group, my teams have suggested a work around that may work out for us if you could give it a try. Please create a new light group and move all of the devices over to this new light group. Once all devices are moved to the new light group, try to delete the old light group. Then, if you can delete the old light group, remove the devices from the new light group and ensure you can now delete the new light group, once all the devices are removed. Let me know if this works for you!

In addition, my apologizes for the lack of support that is available at this time. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. From the longer than normal wait times on the phones, we have had our chat team take phone calls at this time. Please read our response to COVID-19 here to see how to contact support if you need to get in contact when them directly, or if my work around does not show to work for you!

1 Like

No, this does not work as whatever the group is that contains the device, the device can not be deleted from it.

It can be moved to another group, but cannot be deleted.

What your steps end up with is the device in a group with a different name.

2 Likes

Had the same issue and the workaround suggested here did not work so I called support. They had me run the camera through setup again and when it was back up in the app it was out of the light group and the light group was gone. Note they did not ask me to “Remove this Device” from the app as that would have deleted all of the video history.

3 Likes

Just tried this and it works. I put the Spotlight Cam in setup mode, went through the steps in the app to “add” it again (with the same name), and it was removed from the group.
It retained all settings and cloud data.

2 Likes

No, this doesn’t work. According to Ring, grouped devices cannot be shared, but it doesn’t allow to remove the device (wired floodlight in my case) from the group without moving it to another group. It cannot even be installed unless assigned to the group.

This is fine, except that three of my cameras are up on the eaves meaning a climb to hit the setup button.

No reason this shouldn’t be a software fix, and no reason we shouldn’t be able to share groups.

I just bought the ring floodlight to use in an apartment I own, thinking I could invite tenants to control the light. To my disappointment, this bug is preventing that. If I didn’t already install it off the third-floor attic, I would return it. I still might. If anyone finds a workaround please post it here.

I have the same issue… had to borrow a ladder to install which is now returned so cannot re set up…please fix the bug…

Same issue here.
I already tried the setup mode solution and the camera is still at the group.
I’ve tried renaming the camera during the setup, but when it finishes… Still stuck to the group.

Hey neighbors! If the suggestions from Chelsea and @jbernardini aren’t working to allow you to delete the group or remove a Floodlight Cam from the group, please give our support team a call at one of the numbers availablehere. They’ll be able to take a deeper look and provide more in-depth troubleshooting options. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support. Feel free to report back on what support recommends, as it may help other neighbors! :slight_smile:

Note, it appears that I have shared the camera successfully with someone else anyway, even though it says it is not possible, so if you are getting the error message, check that it is in fact sharing despite this…

I’m having a similar issue with a transformer for landscape lighting.

In short, my tranformer is in a group. The app tells me I can’t add a shared user because the device is in a group. But it is not possible to remove it from a group or to set it up without adding it to a group.

In further detail, I cannot remove it from the current group without putting it in a different group: The only options after Edit Group>>"Where are you moving this device? " are a list of existing groups or the option to create a new group. So I can’t move it out of a group, and I can’t add a user as long as it is in a group. The message is “Grouped devices can’t be shared, so they aren’t shown here. To enable sharing for a grouped device, remove it from its group.”

This is a bug. Please fix it and reply, Ring. Or at least reply. The customer service online portals currently state that no customer service is available!

2 Likes

It seems like this has been a problem for a while. I can’t share my devices with my wife because I can’t remove them from the group the software forces me to add them to. Then I’m unable to remove them from all groups. When is this going to be fixed?

2 Likes

Just want to chime in and say that this problem still exists.

I don’t think asking the customer to re-setup the lights is the right thing here. Why can’t you simply delete a light from a group in the app? Seems strange to me. And because it’s group, I can’t share the light with my wife. So either allow us to delete or allow sharing.

1 Like

Ok, if you all are doing exactly this without the intended effect, please forgive me. I’m usually the one stuck who’s about to take a hammer to whatever inanimate object contains the software/hardware that has me stuck. I ran into your post(s) when I was troubleshooting how to make my wife a shared user but I got through it. It helps me to take a step back and look at the big picture while keeping a close eye on terminology. First I want to point out that there seems to be a redundancy in Ring’s design of [shall we say] “how the components communicate and act/react accordingly.” Now putting devices into “groups” sounds simple and intuitive, but doing this results in the “can’t share” issue. Now unless your app/program is different than mine (ring app on iOS), these are specifically called “light groups”. Let’s use a set up where we have a doorbell, a battery floodlight, & a floodlight Camera (plus obviously the base and lightbridge). I’ll refer to them as bell, light, & cam respectively henceforth. When put into a group, or better said a light group, both light and flood can sense motion and simultaneously turn on their lights where as bell can only sense the motion while the other two shed light on the situation (yes annoyingly the pun was intended). Disclaimer, without being a light I don’t know if you can even include a doorbell in a group, just using the example. Now here’s the redundancy I spoke of; in the app we can achieve the same result through settings found by pressing the “linked devices” tab after a specific device is chosen from the menu (so menu —> devices —> linked devices and activate the functions listed for each device. So yes there’s groups and there are linked devices… you can group or link devices… confused?? I was too. I’ll get to the exact key strokes I used to remove my device(s) from the group(s) they were in and in one case deleted the entire group, but I myself was stuck on this thought for a while.
So why even have light groups? Good question. My interpretation & experience is this: a floodlight (motion & light no camera) is not considered a “device” let’s say because it’s not complex enough. Thus ring brought in the light bridge that receives signals from these simple lights can combine them in different groupings (a light group ?). Now as a group these lights are complex enough as a whole to get classified as a device and then will appear under menu—>devices?? and now we can link the functions of this set/pair to a scenario which happens to another device.

Whew ok so here’s the not so explosive conclusion (and I hope you don’t follow these steps and go “yep you ■■■■■, that’s exactly what I did & nope it doesn’t work”). To remove a device from a light group I go to the dashboard then click on the “lights” shortcut (note if this shortcut isn’t there scroll to the right and click on “edit” and you can add this shortcut). Under lights you will see everything listed that has a light, but one section is aptly named light groups. Find what light group contains your target device. Within this light group choose settings —> General Settings —> then EDIT group+. Here click on the blue switch turning it off, and yes just click “remove from group” and press save. From there I tend to arrow back 4-5 screens & even properly close the app, if I’m desperate I’ll shut my phone down and restart lol isn’t necessary but I do arrow back to the dashboard. At this point I was able to repeat this process and even removed the very last light. When I went back in it did allow me to delete the group forever. Gosh I hope this helps as I never post these things and I’ll never get those 20 minutes of my life back. Cheers everyone and goodnight!!

“Removing from the group” is no longer an option. You can only Add to an existing group or Add to a new group when trying this approach in iOS. I also noticed that Ring has dead links throughout their support site on the topic of deleting groups. It seems they may know they have a bug. It would be great if they could acknowledge that. I hate that I bought one wired camera flood and five wired floods, and I can’t give my husband access to any of the wired flood lights because you’re forced into adding the wired flood lights into a group via the bridge - no way to add them individually. There is no way to undo the group, and you can only share individual devices so there is no way to share smart lighting with other users at this time. My advice - don’t buy any of the smart lighting until they fix this issue.

Same exact issue with my ring transformer. Ring support, please help! I have tried everything on this thread.

Hi @BmoreHokie. As this is a neighbor to neighbor support for and not a direct line of support, it would be best to contact our support team directly. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.