Cannot connect to wifi after firmware update

2 of our 3 Ring Video 3 Plus doorbells could not reconnect to our wifi after being taken out for charging. A firmware update was applied to our devices just prior to attempting to connect back to our wifi.
These ring doorbells worked just fine for 18 months of regular battery charging and reconnecting to our wifi. Each location draws 80-105 Mbps. Signal strength has never been an issue. Until now.

The tech support representative’s only solution was to move the doorbells closer to the router. That solution would negate the primary reason of having these doorbells where they were needed. I repeated asking about the potential impact of the firmware update but the representative would not address that aspect.

Hi @SRTESSMAN. What troubleshooting steps have you tried in order to reconnect your Doorbells to wifi? Have you tried following the steps to reconnect your Doorbell to wifi under the Device Health page in the Ring App? If that didn’t do the trick, you can try a fresh setup after resetting your Doorbell, which you can do by holding down the setup button for at least 20 seconds. Once the reset is complete, follow the steps under Set Up a Device to take the Doorbell through a brand new setup.