Cannot connect to Elite Stickup Cam temporarily network

My Elite POE stickup cam suddenly lost connectivity. I tried to reconnect didnt work. I tried to delete it and add a new device.

When I add a new device, it wants to connect to the temporarily network but it keeps failing at that step. Tried maybe 50 times now and it wont work. Other cams still work, just this one is not working. Only used for 2 months.

Hi @125mph. Is your Stick Up Cam Elite entering setup mode correctly? When you press the setup button on it does it speak and say it is in setup mode?

Yes, it blinks blue and then says its entering setup mode. Then the app says it tries to connect to “Ring Setup 03” but fails. It keeps doing that a few times and then the app tells me to connect to the network manually.

@125mph. I appreciate that information. Try the following steps:

  • Make sure your Ring app is up-to-date with the latest updates.

  • Try completing the setup without scanning the QR code, or vice versa.

  • Reboot your phone and shut off Bluetooth.

  • Factory reset your Camera by pressing and holding the setup button on it for 20–25 seconds.

If you have tried these steps and are still having the same concern, give our support team a call for further assistance.