Cannot complete Wi-fi set up on new Ring Doorbell


Merry Christmas.
I have recently purchased a new Ring Doorbell to replace my old one that has just failed. Unfortunately it will not complete setup to our wifi network.

  • On 2.4ghz
  • Reset Modem
  • Tried a different modem
  • Tried reloading app
  • Tried on a different device
  • Tried with cellular data off
  • Tried all the suggested channels (or channels not to have modem using)
  • Performed reset
  • Tried to chat online but tech support unavailable
  • Have reset old device (same model but button doesn’t work) and reconnected it no worries.

Any other suggestions before I take this back for a refund tomorrow? I am in Australia. Thanks in advance.

Hi @Brendan7. Thanks for listing the steps you’ve taken so far! There may be some settings you need to adjust on your phone. First, try turning Bluetooth off and if you have a VPN, turn that off as well. Next, you’ll want to turn off your Smart Network Switch (Android) or WiFi Assist (iPhone). Be sure to make sure you are setting up the Doorbell away from any other wireless devices as this may be causing interference. I hope this helps!