Cannot change wifi network on base station


When setting up my ring devices I had issues when setting up the base station to my home network.

Reading the docs I saw that we cannot have special characters on the password and I had it on my network.

I have created a guest network with the same authentication definitions (WPA2-Personal) without special characters on the password and it worked.

Now I have changed my home network password not to have special characters but it still not working.

What can be done to solve this? Can you hlep?


Hi @pal2000. It’s good to hear that you were able to get your Ring Alarm connected with the guest network. I’d recommend double-checking the different security and firewall settings on your main network, to see if they differ at all from the guest network. If everything appears to be the same, but your Base Station can’t connect to your main wifi network, please give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.