Cannot change network

I have tried about 30 different times on 3 different devices to change my network after changing my router’s network name. I’ve gone through the website help FAQ which is utterly useless and just keeps looping you through the same 2 pages.
1 iPhone
2 android devices
Blinking left, right, top, nothing, no option works.
YES I’ve made sure mobile data is off
YES the type of WiFi is compatible, same router as before, just a new name and password
YES I’ve made sure smart switch is off.
YES the router is in a good spot. Signal green.
YES I’m effing standing right next the frickin doorbell

Near the end of setup after typing in the new network name and password, the ring circle up-scrolls blue twice then starts blinking left. By the time the app asks if it’s blinking left, the ring has stopped blinking. Again, none of the 4 blink options works, so I have to start over.

Is there a way to hardlink into the ring with the USB port? This wifi setup is ridiculous and buggy. It took forever the first time we originally set it up, too. This is literally the only piece of tech in my house that doesn’t work regularly and is having trouble with the Wi-Fi name change.

I don’t know exactly what Ring has broken or coded so terribly in their system… But to finally fix this I had to create a WiFi hotspot on my phone, using MY MOBILE DATA, with tye exact same name and password as my intended wifi home network. I had to then disable the home WiFi router. THEN use a SECOND different device, a tablet, to go through the Ring app and setup/change the WiFi network. THEN …it finally worked. THEN disable the hotspot on my phone, THEN enabled the home WiFi router. Doorbell connected of course to that network since it has the same name and password as the hotspot.

What. The. Frick. Have. You. Done. Ring? Seriously???

This Ring doorbell and everything in this ecosystem around it are about the most useless and frustrating IoT device ever!!! I will NEVER buy devices from a company so stupid ever again!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.