Cannot change neighbors address

So my “neighbors” address is different from the actual address for some reason. I’m guessing their location search goofed up and permanently tied me to the wrong address. I’ve tried searching through the forums. This looks like a bug that’s still around for years now.

“This address is linked to one or more locations on your ring account. To change it, open the side menu, select this location, then tap Settings, then Location.”

  1. Opened side menu. Check!
  2. Select this location. Wait, what? Where??? The only location I see is the actual address. I don’t even see the wrong "Neighbors address that I need to get rid of.

I’ve tried the same steps and uninstalling/installing both the Ring and Ring Neighbors app on my phone. I went to the website; useless.

Hi there, @lsuvince! This sounds very similar to this recently solved Community thread. If you were unable to correct your locations information in the Ring app, please download the Neighbors by Ring app, log in, and change you location information there.

If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

@Marley_Ring I have had a support case open since 2020 when I tried what the OP asks, and all I keep hearing is “we’re working on it” I just responded back to my email from January to see if I get the same cut and paste responses people in the forums have been trying since June 2018 was the earliest I had seen. I’m not holding my breath. I’m really getting sick of following up on this where it can’t just be updated in the neighbors app independently.

You basically recommended me to do what I stated in my original post.

I’ve tried everything in the other community posts.

I’ve tried changing the address in the Neighbors app.

Both the Ring and Ring Neighbors apps pop up the same message telling me to go to the Ring app, and choose the location that isn’t even available in the dropdown. Also, the popup states there is Location section under Settings. There is none.