Can’t view one camera

I have a doorbell and 5 cameras. They all work perfectly in Ring and have in rapid ring in the past. Starting about 2 weeks ago, one of the cameras always times out in rapid ring. Can’t view video. It works perfectly in Ring. Signal is strong. I’ve tried re-setting up its wifi connection, & reinstalled rapid ring without resolution. Again, works perfectly and strongly in Ring. Same camera won’t view in rapid ring. Help. Thanks. .

Hi @Russmd. What is the RSSI for this device? I would also try rebooting your internet router to clear up any network congestion you may be experiencing. Also, you may need to make some adjustments to your router. This Help Center article here has information on the Ports and Protocols the Ring app uses. Let me know if this helps!

1 Like

Thanks Tom. The RSSI is -50, stronger than several of my others that work fine. I will look at the router adjustments but I’d be surprised if that’s it considering up until a few weeks ago it worked fine AND it works fine in the native Ring app. All the other cameras show fine. The reboot is easiest of course and I’ll try that first. Thanks.

1 Like

No go on the router reboot. There’s no reason to mess with the ports seeing as all the other cameras work fine in both apps and the involved camera works fine in the native Ring app. I’m stymied.

1 Like

Hi @Russmd. Thanks for the updates on what you’ve tried so far. Do you have access to a different smartphone or tablet that you can download the Rapid Ring App on? If so, please try accessing the Live View to the Camera that you’re experiencing this concern with to see if the same thing happens on a different smartphone or tablet.

Thanks Caitlyn. Yes, I also use Rapid Ring on my iPad and same problem! I rebooted the router, unplugged and re-powered the affected camera (it’s wired), re-paired it with the wifi network, logged out and in on the app, deleted and reinstalled the app - all without success. As I said, the camera works perfectly in the native Ring app with RSSI -50. My doorbell and four other cameras work perfectly in both apps. And this particular camera used to work fine in Rapid Ring until about a month ago. How crazy is this! Any other ideas?

@Russmd Thanks for giving that a try. Since the Live View is still not working on Rapid Ring for that device, can you please follow up with our support team so they can look into this further? You can give our support team a call at one of the numbers available here, and you can reference this thread as well so they can see what you’ve tried so far. If you are outside of the US, please visit here to see how to contact support.