Can’t get ring pro to turn on after install

Argh, please help.

Went to install my new ring pro doorbell a few weeks ago. No spinning blue lights, no ring network, Thought my transformer was old. (16v, 10a) New transformer is in, (24v, 30a) still no power to the doorbell.

Multimeter shows 18volts at the ring doorbell, but it just doesn’t turn on.

When I scan my QR code it tells me there is already an owner, it might be me from a few weeks ago, but I never got farther then looking for the spinning blue light that was never there. There is nothing listed under my devices in the app. If I scan the Mac id, it lets me start set up but since there is no blue light on the ring, it can’t connect.

Is there a chance I got a used, broken ring pro?

Hi there, @Statik81! Did you purchase this Ring device via or an authorized seller as new? If so, there should be no previous owner, although if you tried a previous setup using a different account this may result in a change of ownership needed.

The power supply is certainly sufficient for powering the Doorbell Pro. I recommend also ensuring the wiring is not too thin, corroded, or lengthy, and is connected securely. If there are no lights coming from the Doorbell Pro at all, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.