Can a firmware update totally brick a Ring device?

Just want to see if anyone had this happen where a firmware upgrade to a Ring device totally broke it and bricked it to the point where it no longer works and can’t be reset even?

I installed a Ring Floodlight Cam - it was all good. It connected to my WiFi, had great signal, I could see the live video but then right after the initial install while I was still adjusting the camera and lights I heard it say that it was doing a Firmware Upgrade. Then right after the flood lights turned on and stayed on permanently. The camera went offline and never came back on even after several hours and turning power off/on. Also the reset button on the device does not do anything so can’t even put it back into setup mode.

Am I the first to experience this or are there others?

I have installed 4 other Ring devices outside my house and this is the first time I had this issue.

Hi @JetRocket11. I have to admit, this is also the first I am hearing/reading of this. Our support team will be best to help you out further with your Floodlight Camera in this situation. They have the option to reboot your Camera with the firmware it needs by reverting back to an old firmware and letting the Camera go through an update again. I recommend giving them a call here, and let me now how the call goes and if they get it resolved for you! Anxious to hear of the outcome in this unique situation. :slight_smile:

Hi @Chelsea_Ring

I am already exchanging the Floodlight Cam - sent it back to the place of purchase yesterday.

However, I did call your support initially. They had me try pushing the setup button at the top of the cam which did nothing. Also turning the power off/on did nothing to reset it.

It would turn back with both flood lights on right away and stay that way. The camera itself would have one green flash at the bottom after initially turning the power back on - also for a brief second a line of red LED’s appears where the camera lens is.

I guess there was nothing the support could do remotely since the camera would no longer connect to WiFi.

2 Likes

Firmware update bricked my doorbell as well. Ring know about this and are doing nothing to resolve the issue. Looks like they are killing off older doorbells like Apple do with older iPhones.

As long as you’re within warranty, @Arniej, we will assist with replacing your device no matter what happened. Our team is also dedicated to get you up and running and assist however we can.

I don’t know if it was caused by a firmware update by mine just started exhibiting the same symptoms a week or so ago. It was turned off at the switch because of activity in the yard and in the next day turned back on. Light came on, stayed on. Couldn’t connect device and holding button did nothing. Only bottom led flash comes at first turning it on.
Of course it will be the first support has ever heard of such a thing, every time they are told the same thing.

I’ve just had the exact same thing happen with a spotlight cam mount…

Same thing just happened to me. Assume no one ever got a proper answer to this?

Nope. Had to get a replacement. Luckily that one worked ok.

To date the firmware update has bricked 4 ring indoor camers 11/2020. I recent purchased the white indoor camera from lowes during black Friday and after the initial setup the camer performed a software update. That was the last time all four camera worked. I have returned them to lowes, not sure why ring is bricking there camera but it is getting tiresome.

Yes, happened to my spotlight mount. I ordered 2, 1 was fine and the other bricked at the firmware update. Swapped for a new device and all is well.

Absolutely, and the unfortunately fact is if your device is out of warranty, you are only offered a small discount even though thier upgrade broke it. I just occured to me this week. While Ioved the Ring Doorbell I do not think it may be worth the risk.

I’ve just had exactly the same thing happen to me, although I wasn’t aware that it had something to do with a firmware upgrade.

Has a solution been given/provided/found?