Cameras don't honor mode settings

Hi there,

Both of my cameras (Indoor Cam, Stick It Up w/ battery) have suddenly started to ignore mode changes, forcing me to manually change their settings.

For instance, I have configured the Indoor Cam to disable motion detection while on Disarmed mode. However, when I switch from Home to Disarmed, the motion detection is still enabled, and I have to manually disable it.

See this video demonstrating the example above:

  • At 0:00 you can see that the Home mode is currently active.
  • At 0:08 you can see that the motion detection is disabled on the Disarmed mode settings.
  • At 0:18 you can see how I switch to the Disarmed mode.
  • At 0:21 you can see how the motion detection is still enabled.
  • At 0:24 I manually disable the motion detection.

As said above, this happens in both of my cameras, and it was working fine before, so I wonder if a recent update has caused this. I made sure the app is up to date.

I tried various things:

  • Remove cameras from my account, factory reset them, and set them up again.
  • Temporary modified the mode settings and revert them back, to see if the settings were somehow cached.

Nothing worked. How can I enforce the cameras to respect the mode settings?