Camera will not connect to my new wifi

I have a new fibre optic wifi(Jetnet) that I am transitioning to for my ring alarm system but I am having camera connection issues on both cameras, all other devices are ok. Also if I have no connection issues using my using my original wifi provider(WIMAX) vía a dish which hasn’t been disconnected as yet.

The base station recognises Jetnet router as contacts, pies, extenders. When re-installing the two cameras, and selecting the new wifi network(jetnet), it asks for the wifi password does it’s thing, and sits at 95% complete and fails with:

Hmm, something went wrong.

Sometimes, devices just don’t want to connect to the Internet. To solve this, tap Try Again.

If that doesn’t work, try restarting your Wi-Fi router.

If this continues, you may need to change settings on your router or modem.


Does anyone have a solution? I have tried unplugging the router.

Hi @user62029. Thank you for troubleshooting and trying to fix your concern. I would also recommend factory-resetting both Cameras and then trying to reconnect them to your new wifi. To factory reset your Camera, press and hold the setup button on it for 20–25 seconds. We also have this Help Center article with other steps to try. If you have tried these steps and are still having the same concern, give our support team a call for further assistance.