Camera setup stuck in loop

Hello,

I just got 2 spotlight cams(battery) and the floodlight cam. I’m stuck at the part of the in-app setup where it tells me to press the button on the top of the cam, then tells me the flashing light means the camera is getting ready to connect with the ring app, then asks me what color the light is on the bottom of the cam(which I assume should still be flashing?), then when I answer what color it is, this all repeats starting with telling me to press the button on top. And this loop repeats endlessly.

I have good wifi, and have tried this within a few feet of a router, have tried it within a few feet of a range extender, within a couple feet of the base station, and have tried it with my cell phone’s smart network switch AND mobile data turned off. The problem is the same on both spotlight cams and on the floodlight. I’m at a complete loss here.

Anyone know what’s going on and a fix for this? Much appreciated.

Hey @pjprice79. It sounds like the device is unable to connect to the Ring AP and/or go into setup mode to connect to said AP. When you press the setup button on either device, is the dome at the bottom flashing when doing so? If the dome is not flashing a white blinking light at all, please try resetting the device by pressing and holding the setup button for 20 seconds. Please note that when doing this setup process and connecting to the Ring AP, you must be near the device with your phone (as close as you possibly can for a faster connection), as your phone is trying to connect to the network it is broadcasting. I recommend trying another phone for setup as well, as bluetooth restrictions on some phones may prevent the connection from happening as well. Let me know how this goes! :slight_smile:

Thanks so much! That worked. I had to borrow someone else’s phone, which is kind of annoying but that sounds like something with my own phone and not with Ring.

1 Like

@pjprice79 So glad that worked for you! :slight_smile: