Camera Previews Not Available

I have seen many posts on this issue, but I have not seen any solutions. I just purchased two stick-up Ring cams (3rd gen, wired) and they are working fine EXCEPT I keep getting the message, “Camera previews not available” when I view my dashboard at See attached picture. However, all my previews are available and work fine when I view my dashboard on my iPhone. I am using the Chrome brower, but I have the same issue with Edge. Why does this work fine on my iPhone but not on my laptop? My 1st gen camera does not have this problem.

Hi @garyc6. Try rebooting each of the Stick Up Cams using the reboot option in the Ring app. This should only take a few moments for each Camera. After that, navigate back to and check if the Camera Preview is enabled. If it’s not, can you let me know which versions of Chrome and Microsoft Edge you’re using? Do you have a VPN of any sort enabled on your computer?

Hi Caitlyn. Thank you for the fast response.
I rebooted each of my Stick Up cams individually using the reboot option in the Ring app on my iPhone, but the problem still persists.
I am using a Dell XPS 9520 laptop with Windows 11.
Chrome version: 117.0.5938.132
Edge version: 117.0.2045.47
I am not using any VPN.
I have attached a screenshot from my iPhone 15 to show the camera previews work fine on my iPhone, and they also work fine on my iPad Pro. However, the Gen 3 camera previews still do not work on my Dell laptop, although the Gen 1 camera preview does work.
Do you have any other ideas to solve this problem?

Hi again Caitlyn. Just checking to see if you have seen my response. I would be very interested to hear if you have any more suggestions to fix my Gen 3 stick up camera preview issue on my Dell laptop. Thanks.

Hi @garyc6. I am happy to chime in. Thank you for sharing that additional information. The next best step is to contact our support team for further assistance. They will be able to take a deeper dive into your concern. You can also reach out to support team on Facebook or Twitter (X) by sending a PM to @Ring.

Sadly, the first and second-level tech support teams were of no help for this issue. However, I did figure out the problem myself and found a creative solution. If other customers are having the same problem, the solution below might be helpful for them although Ring would probably never recommend it.

I determined the problem was occurring because I was using a 3rd party 5V DC extension cord so I could run the power cord through a hole in my wall to the camera outside. Ring apparently thinks their customers have power outlets outside or wants us to buy batteries. I do not have any outdoor outlets, and I don’t want to climb up nearly 20 feet on a ladder every time a battery needs to be changed. So I needed to run power through a hole in my wall, but the right-angle barrel connector requires a hole nearly 1" in diameter to fit through and I refused to make a hold that big. Unfortunately, Ring does not sell a power cable that is compatible with their Gen 3 cameras AND has connector that will fit through a 3/8" diameter hole. Therefore I took the factory power adapter cable and cut it into two pieces. There are two small wires inside, a red one and black one. I plugged the barrel connector into my camera outside and threaded the cut cable through my 3/8" diameter hole. Then I stripped off a little insulation and soldered the small wires back together and covered everything up with black electrical tape. PROBLEM SOLVED, but I will never understand why the preview problem occurred only on the website while the previews worked perfectly on my iPhone and iPad apps with the 3rd party extension cable.

I am having this same issue in all browsers.

Firmware is updated, a reset on the cameras was done, RSSI is strong, live view is fine, they are wired in with no 3rd party components, works completely fine in my app.

I have over $1000 invested in these cameras not to mention the time taken to install and troubleshoot.

Does anyone have a solution for this?

Can I get some help?

Bumping this until I get some help.

Hi @airban. If you’re unable to find assistance in the troubleshooting shared here, check the marked solution in this thread for the help you’re looking for.

I have done that and had no response. DM’ed on X and nothing for 8 days.

Hi @airban. I’d suggest sending a follow-up message, or even reaching out to our support team via phone for immediate assistance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.