bug with new recording length options?

My Spotlight Cam got the update with the new recording length option. The recording itself seems to be working but there’s potentially a bug with the playback.

I’m on Android, app version 3.29.1. The issue I’m having is that if I go to “Event History” to view the recording then I only get 42 seconds of playback. The video opens in the fullscreen, landscape orientation. The trackbar on the bottom actually says that the video is only 42 seconds. If instead I tap on the camera preview to go into the timeline view then I can actually see the full recording. There’s one video that shows as 38 seconds, but most if not all the others stop at 42. The recordings themselves are all 60+ seconds long though.

Actually, I also have a Floodlight Cam and noticed that all of the videos under Event History show up as being 1:05 – 1:07, which seems odd since they are supposedly 60 seconds.

I just tried it on my iPad and it’s actually worse there. I get the 42 second videos in both viewing modes. I also tried downloading the video and only got the 42 second version instead of the full two minutes.

Thank you for sharing your experience with us, @estmatic! It definitely seems odd that a recording will show a different length than that of your event recording or video length duration setting. Some variables to consider here are advanced motion features , or motion stop. While the motion stop article describes a default of 20 seconds as an example, this can apply to all video recording lengths.

If the above does not match your concern, please share a screen recording or image example of this concern, so we can take a further look for you. :slight_smile:

I now saw what is actually happening. See the video here:

  1. I start in the timeline view. Notice that the time on the bottom left of the video is going faster than real time. The video is not sped up, it’s just the timer that is incrementing too fast.
  2. The sped up clock goes through about two minutes in less than one real-time minute.
  3. I then expand the video to full screen. Notice that the time is still flying by, but the video length on the right of the trackbar shows that the video is only actually 42 seconds long.

Of note, I did not have the motion stop or motion verification features turned on at the time of that recording. That video should have recorded a full two minutes, but it didn’t apparently. Regardless, I do have motion verification turned on now. On a new video from this morning I see the same sped up “two minutes” but the video is only 42 seconds. The motion verification didn’t seem to do any trimming even though the actual motion event ended after about ten seconds. Though there are some tree branch shadows so maybe it was looking at those.

I finally had time to call support and go through their troubleshooting. So apparently it is possible to have the recording length available in the app before the cameras themselves are updated, which is pretty silly. I have the option in the app set to record 120 seconds, but my camera still thinks it can only record up to 30 seconds (even though it ends up being 38-42 seconds). Also, on playback the Android app thinks the video should be 2 minutes so it speeds up the timer (only in the timeline view) to compensate for the actual, “shorter” video length. This doesn’t happen on the iOS app, the website, or even the Android event history view.

Basically all I can do is wait for the camera to update. Supposedly they will send an email out to when the feature is enabled. I don’t know if that’s going out to individual people as the feature gets enabled on their account or if that’s going to be a global email once it rolls-out to the entire userbase.