Bug report - ring sensor disappears from system

I just noticed a door sensor DISAPPEARED completely from my app. No notification.

Couple problems with this.

  1. There needs to be a BIG ALERT / EMAIL / Notification any time a sensor is removed from the system
  2. This bug needs to be fixed - No one touched the sensor (and in talking to customer service the PROMISED there was no way a sensor could be removed without pushing a button on it - yet THAT IS WHAT HAPPENED!

In going through the logs, I see the sensor indicate 'OFFLINE", and then the same second ‘REMOVED FROM SYSTEM’

Since we didn’t do this, it’s some kind of short or electronic failure.

This is a gen1 sensor. Probably a couple years old. Unknown if the battery died or what.

Phone customer service would not let me submit a bug report and was totally dismissive.

Regardless of the cause of the problem, adding an ALERT that needs to be acknowledged in the app is urgent - something like a pop-up when you log in to the app that says ‘a sensor has been removed’ . And a link to either a) Yes, I know about that it’s ok or b) News to me, tell me more

It’s completely possible this sensor could have been off for months and I never would have known since I didn’t touch it or make any changes in the app. I just got lucky I happened to test the next day.

Hi @dingaring2. Thank you for sharing your feedback here. Regarding your suggestion for a notification when a sensor is removed, you can add that to our Feature Request board. This will help us to organize and share your requests with our teams here, as well as allow other neighbors to comment and add interest, all in one place. Feel free to link that post you make in the Feature Request board here so other neighbors that come to this thread can easily find your idea!

As for the Contact Sensor itself, have you been able to get it added back in through the Ring App, and have you noticed any other concerns with it? If this happens again or if you notice anything else off with the sensor, please follow up with our support team. Let them know you called about this concern previously as well so they can review that information. You can give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

I can’t get the sensor to reconnect. There’s still nothing in the logs that indicates WHY it disappeared, but there is a log entry of ‘factory reset’. But again, the cover was never removed or damaged, so this was a apparently a spontaneous removal.

Unfortunately the support rep I spoke with told me to sensor AWAY from the the latch to remove it from the wall. It’s the opposite - you pull TOWARD the latch. I struggled so much with going the wrong way, by the time I pulled it the right way I hit the internal components and looks like I broke off the antenna, so system doesn’t find it. Also the support rep wasn’t aware the the PIN / QR code is also under the cover of the sensor (not just on the bottom) - so there was no need to pull it off the wall in the first place.

I had a contact sensor do that a few times a couple of years ago. My sliding glass door would factory reset and be removed even when the system was armed. It’s a bad sensor and needs replaced. When the device reports a factory reset, the ring hub will also remove it from the system. They should ship you a new one and request that yours be sent back for diagnostics.

@dingaring2 Have you followed up with our support team about this? It does sound like this Contact Sensor may need to be replaced like @NathanH mentioned since you’re having concerns with getting it reconnected. It’s possible there was a problem with the Contact Sensor’s firmware, but it’s hard to speculate and really our support team are the ones that can look into your account further. If you do follow up with support, please do let us know how that goes! Feel free to reference this thread when you reach out as well.