Bug Report: Echo Show not automatically showing - proven reproducible issue with workaround.

Right. Up until today I was unsure if this was a bug but after figuring out how to work around the issue and how to reproduce it, I’m convinced it IS a bug.

Last month I installed the Ring Doorbell Pro from scratch and installed the Ring Skill in Alexa which would announce and automatically connect to the Echo Show to display when someone rang the bell. This has been working for an entire month without issues.

Last week I renamed the Echo Show to another name and since then it’s only been announcing by voice that someone is at the door. Not displaying automatically. Although it does let me ask to “see the front door” on demand.

I have since then attempted to correct this by:

  1. Renaming the Echo Show to previous name

  2. Unregistering the Ring Skill and re enabling

  3. Factory resetting both the Ring Doorbell and Echo Show

  4. Re linking all devices

No luck. I have spoken to both Ring and Amazon customer services who suggest it is an issue on the opposite side(i.e. Ring vs. Amazon) but no one has been able to tell me what’s wrong.

So instead I removed the Echo Show and Ring Camera from my Alexa account. Then used my wifes Amazon account to register Alexa and do a fresh new registration of the Echo Show(after factory reset) and installed the Ring skill for the first time against the account. This worked! The Echo Show now automatically displays upon doorbell press. I am not going to be renaming the Echo Show as this will break it again to be voice only.

I have a feeling, the name change got ‘cached’ somewhere and is conflicting with the amazon Alexa account and so only one side of the feature is working. i.e. voice announcement only. Upon renaming somethings not being wiped or reset correctly and being relinked in the Ring Skill.

Unfortunately neither Amazon or Ring are taking ownership of this issue but I think this is an issue with the Ring Skill because the Echo Show is functioning as it should. The skill becomes corrupted when renaming the Echo Show against an account and the only way to fix it is by creating a new Alexa account entirely and re enabling the skill.

Hope this helps to describe the issue, Ring mentioned to me that others have also reported this issue.

3 Likes

Hi @MaroofC. First and foremost, thank you for diving into this concern and sharing the details of what you discovered with us. We’d be happy to flag this with a member of our team so they can take a closer look. Do you mind letting us know what your Echo Show was originally named and what you changed the name to? This would be great information to include as we pass it over. Once I get that information from you, I’ll make sure to send it over and let you know what we find! :slight_smile:

Hello

Sure - intially it was ‘Maroof’s Echo Show’, I renamed it to ‘Main House’, then renamed it back but the issue persisted.

Thanks

@MaroofC Thank you so much for the additional information, neighbor. Rest assured I have passed on this information to the appropriate teams so that they can take a deeper look into this. I will let you know if there is any further information we may need, but will update you here when their investigation is done. :slight_smile:

Was there any update on this?

@MaroofC Currently, there is no new update to this concern. I’ll be sure to share an update as soon as I receive one from my team. :slight_smile:

I am experiencing the same issue with an echo show I set up today. It would be nice if there was some kind of warning in the documentation since this is a known issue. Is there an ETA on a fix for this?

Agreed, because of this I’m having to use my wifes Amazon account so I can’t use my echo devices for Prime Music etc. It’s a shame Ring are not being proactive about this feature but easiest temporary fix is to use a new Alexa account on the devices and then link those.

I have the same issue - I cleaned up my names for my 5 Echo Shows and it screwed everything up… I now only get the audio alerts… even though I have both Announcements and Live view shown on the device list.

I remember changing the name on Echo myself. Thanks for the tip. I will give it a go.

Would be great to get some news… Have that issue. I’ve cleaned up my Show names, I have 5. And none will show the Live View…

This is definitely still an issue, however I renamed my echo show back to what it was and it started working again.

Its lucky yours was fixed after renaming back. As I tried that however it didnt work. It must be unlinked somewhere. I cant believe Ring are not taking this one seriously.

Wanted to chime in here. I got a few new Echo shows during prime day. One for my moms, one for dads and one for me. I set up mine and when the doorbell rings it shows without issue. Did it at my moms house, with her amazon and ring account, no dice. Went to Dads, different house, different accounts, different devices, same issue.

What is the fix here Ring?

I’m having the same issue. Just received new Echo Show and tried it for first time, announcement is working but no Video. Everything works fine on Cell Phone. Really disappointing, unless fixed will probably be returning the product.

Its been almost over 2-3 months when this was originally reported and the issue is now still present for new and existing echos despite name change or not.

I think I may switch to Eufy

Bringing this once again to the attention of RING. Doorbell only announces on the Echo Show but does not automatically show as it did a few months back. Skills have been uninstalled and reinstalled. Still no progress. Echo only announces but does not show.

Its a big disappoinment that despite paying for this service that Ring choose to ignore this

and today there’s no announcements visually or verbally !!

Sorry to hear this concern is persisting, neighbors! As mentioned prior in this thread, removing and reinstalling the Ring app and reapplying the Ring skill for this might help. Please also ensure that wifi connection is optimal with your Ring devices and the Alexa enabled devices in your home. As long as you are able to access live view from your Ring app, this should work as intended on your Alexa enabled devices too.

If this is still not resolved, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Tried all that then also called support who suggested the same steps. This is a technical issue on Rings side as it is occurring for several people, including my friend.