Beware - Ring Video Doorbell Issues - re: Snapshot Capture and firmware issues

I see that some posts on this Video Doorbell room have been deleted. One deleted post was titled: “Snapshot Capture not working Ring Doorbell Pro” and it was posted 12-30-2019 9:33am. Thank you Google Search Cache.

Please beware…regarding the issue that I will copy in below from my cached post. I wonder why Ring deleted that post…was that post in any forum violation? Or, is there another reason?

"My snapshot Capture doesn’t work on the Ring Doorbell Pro. Snapshot Capture works on 1 of my 2 Ring Floodlight cams, and, both of my Ring Indoor cams.

The Ring Doorbell Pro has RSSI of -63 and records video well. It’s stuck, however, on firmware 1.16.00272

I’ve done all of the troubleshooting from re-installing the app, hard reset on the doorbell, rebooting the wifi, etc.

What’s up?"


Let me help with a resolution on this matter.

Today I returned my Ring Video Doorbell Pro and for some reason, decided 1 more time to exchange it for a new one.

I installed the new one today, and noticed that the Firmware was 1.16.00263. I thought…gee, now I’m going backwards when my prior defective device was stuck on Firmware 1.16.00272. But, in under 5 minutes of having the new device installed, the firmware was updated and now it shows, “Up to Date”.

Guess what…I have Snapshot Capture now.

So based on my experience, the fix was to return the defective 1.16.00272 device and I was fortunate to have picked one up that updated correctly.

Now, was that so hard?

1 Like

Hey @Nacho ! As this Snapshot help center article states, our team is working hard to bring Snapshot, and many other features, to all neighbors’ devices as we speak. While your experience is not at all one we intend for our neighbors, I’m happy to hear you’ve obtained the Snapshot feature!

In regards to our Community team and Guidelines, we are a team of experts with Ring and are happy to assist with anything we can, or at least point you in the right direction. We are also here to ensure the Community remains a favorable environment for all neighbors, with constructive feedback and positive interaction. Please review our Community Guidelines at your earliest convenience. Keep in mind, spamming extends to a repeat posting of similar content, as our neighbors benefit most when a topic is in one place.

Dear Marley_Ring -

Thank you for the reponse.

I’m still puzzled because per the excerpts in quotes below from the Snapshot Help Article that you provided (and that I have read before) I don’t know how “new device setups” is defined. How is that defined? How is “existing devices” defined? I understand that you cannot comment on what “soon” means.

"Note: This feature is currently available on new device setups. Access to this feature will be available for existing devices soon."

Further, there is contradictory information in this article…see below:

"** What Ring devices have the snapshot capture feature?**

Snapshot capture is available on all Ring devices."

Let me help readers of this thread further understand and benefit from my experience thus far related to the post’s topic…

My first Ring Video Doorbell was received with Firmware 1.16.00272. That device did not update the firmware and it did not have Snapshot Capture working. I purchased this first device mid-December 2019.

I returned the first, and purchased a second. The second had the same issues with the same details. I did this transaction a few days after I purchased the first.

I returned the second and replaced it with a third (today). The third Ring Video Doorbell was received with Firmware 1.16.00263. I think we can all agree that this firmware and the associated device is therefore and older device. However, this older device updated the firmware automatically to “Up to Date” and that resolved this issue.

So again, there is much confusion for me as a consumer as to the definition of “new device setups”, “existing devices”, and what appears to be contradictory information on that same help article that, “Snapshot capture is available on all Ring devices.”.

So my original question is not yet answered…whether my first and second Ring Video Doorbells were “bricks” - meaning to me…that they would never have updated their firmware and my only solution was to return the device and hope that I received a functioning one.

Furthermore, and related to this thread, my Ring Floodlight situation is similar. My first floodlight that I purchased and installed worked very well - updating its firmware to “Up to Date” and providing things such as Snapshot Capture. On the box, that floodlight shows, “Assembled in China. 2017 BOT Home Automation”. My second floodlight that I purchased a few days later shows on the box, “Assembled in China 2019…”. However, this second floodlight does not update to the “Up to Date” firmware and is “stuck” on 1.16.00273. So again, in this case, the older product appears to be the functioning product and this seems contradictory to the help article that you provided.

I’ve read the forum rules and I believe I’ve followed them. I don’t recall having duplicate posts that would have required deletion - if anything - perhaps a merge (which I know can be done in these forums because it happened to me a day or so ago).

So again, the help from Ring on these forums for me has been absolutely useless to me and my issues with Ring. Same with calling Ring customer support. I’m here spending time posting my experiences in order to help other consumers - inline with forum policy - and some critical posts that I’ve made have been deleted by Ring - that in my opinion did not merit deletion based on forum rules.


I actually think Nacho makes some good points. I too have a Video doorbell Pro with an almost identical experience. Firmware stuck at “1.16.00272” and non functioning snapshot capture. I have contacted support several times and have reset and and reinstalled doorbell, removed and reinstalled app after rebooting phone, reset wifi, moved Chime Pro. Nothing seems to work and support has been unable to resolve. Last call the tech said they were running diagnostics on my devices while waiting for reply we were disconnected and i have yet to recieve a follow up email or phone call. I guess they are waiting for me to call back again and wait in the que to start the process all over again for the third time. I guess my only real option (as user Nacho did) may be to return the device and hope i get lucky and recieve one that works, although i was really hoping Ring support had some answers and most of all a fix.

Note: I also own a Flood light Cam it works fine all features but on that device firware indicates “Up to Date”.

I hope that you resolve the issue.
It’s been hard for me to be a Ring customer because their products didn’t work as specified and there was no help on these forums or on the phone with Ring customer support. For example, I had to purchase 3 Ring video cams before I got one that worked.

1.16.00272 is where mine is at and all works just fine so If it updates it updates? they will push it to everyone in time like cell phone updates, just takes time to push :slight_smile: don’t be in such a rush, it will come before you know it :slight_smile:

Maybe your onto something, waiting 22 days could be rushing it. I’ll give it a couple months. I’m assuming at this pace they have a human pushing these updates one at a time ??. Then again if I want to rush it, I could just run over to Best Buy and return it.

1 Like

Update: I talked to RING support today regarding snapshot video capture feature not working and the device being stuck on firmware 1.16.00272. After some more failed attempts by support to force a fireware update they informed me there is a known issue with firmware not updating and that they are working on a fix, no eta. They also stated that someone would followup with an email once a resolution was achieved.

I also asked the customer service rep why RING does not post these types of details to the community message board. I suggested that posting and acknowleging an issue could save RING support from needing to troubleshoot a problem that there is no current solution for and thus wasting customers and supports time in the process. Not sure if that suggestion will get any traction. Hopefully the Forum managers and moderators will see this message and can offer some additional insight. What say you managers and moderators?

I also had to scrap the idea of returning to Best Buy since i exceeded thier 15 day return window…arrrrrrg

Tom L

1 Like

lol! I love the sarcasem and lol 22 days is rushing…:stuck_out_tongue: and yes you could return it but why? it works great as of right now even with out the firmware that is old as dirt…lol

I was also thinking of some guy on a computer pushing a update 1 at a time for years…lol!

Figured i would provide an update. I posted in another thread as well. All is well in Ring land my firmware now shows “up to date” and the the snapshot capture is working…boo yah Not sure if they took some action on thier end all i know is that it is working and firmware is indicating up to date. I did place another support call yesterday(4th one) and they performed another remote reset of device and I removed\reinstalled app on phone, all steps performed in the past. When we ended the call yesterday, issue was still not resolved but just start working a couple hours later. For those that are experiencing this same issue the only advice i can offer is be patient and persistent, keep calling support until they resolve it. When you work with support keep it simple focus on the firmware not updating or having the “up to date” status , once that is resolved I believe everything else will fall into place. Bottom line they were able to resolve issue without the need to take it back

Rocxylemmon, Looks like that hi tech employee finally got around to me, pushing that update 1 at a time . thanks for having a good sense of humor.

Tom L

1 Like

So for the 5th time i believe i lost count how many times i changed , i installed another Pro doorbell which was supposed to be from A stock whatever that means(supposedly the most updated ) and unit still has old firmware 1.16.00272 and not showing up to date and no snapshot feature and does not update itself i am so disgusted with ring and the whole thing after reading time again that people on ring community had same problems and gets rectified sometimes a company as big as ring cannot get rectified last conversation they said there aware of firmware problem and it will automaticly get updated and ill be notified but dont know when un real they cant figure out the issue i will never reccomend a ring device to anyone

It took about 4 to 5 weeks before my pro updated. Now it’s up to date and working fine so far. Been updated for about a month with no issues.

I just replaced two Ring Video Doorbell 2’s with two Ring Video Doorbell Pro’s a little over a week ago. The main reason for the switch was the motion zones on the Pro’s. I’m very much enjoying that I’m not getting false motion alerts every time a car goes down the street. Very nice upgrade except that one of my new Doorbell Pro’s is stuck not updating with the same plagued firmware that everyone else is reporting an issue with (1.16.00272). I’ve been in touch with Ring multiple times and have been told they’ll fix it when they can and that I’ll be notified via email when it’s done. I’ve tried to call back to escalate since others have said their’s have been updated and I’m just told my ticket is already escalated and that my device mac address is tagged with all the others that have the same issue. Since this issue sounds like it has been around for a while, why isn’t it resolved yet? Very confusing and frustrating. Biggest thing I miss is the snapshots since I had them working on both of my RVD2’s prior to replacing them. Anyone else have any new interactions with support to share on this issue?

As I posted above. It rolls out slowly. It took 4 to 5 weeks without me calling. But it came one night and has been perfect since. Just have to be patient.

Updated to Android Ring app v3.22.3 (2/21/2020)
Ring Doorbell Pro Firmware version: 2.2.00097

I don’t see a Snapshot Capture option under Video Settings.