Battery shows instead of hardwired

Doorbell has worked fine for over 2 yrs but now shows battery instead of hardwired and battery dies. Was told wires are not connected right so tightened wires then it’s good for a few days and then goes back to showing on battery again. Very frustrated.

Hi @Pjb. Thanks for letting us know what you’ve tried so far. Have you checked the wires themselves to make sure they’re not frayed or thinning anywhere along the circuit? Additionally, have you checked the wiring at the transformer to make sure nothing appears loose on that end? If you’re not sure where your transformer is or if the wires themselves look good, I’d suggest contacting a licensed electrician to take a look. You can also touch base with our support team at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

Yes I checked the wires several times after talking to your rep last Saturday. It has been going back and forth between showing hard wired (which it is) and battery. Later this morning it went back to hard wired and has been there so far. I see where a lot of people are having the same issues and not getting help. It’s frustrating. I was going to buy another one for back of house but no anymore.