Battery ring spotlight camera

My Ring spotlight camera is not turning on…

I recharge the battery fully until green light is on.
Insert into camera - nothing happens.

Tried holing ‘setup’ button but noting turns it on.

Light beside battery bay is solid colour for about 1 day then it is flashing the next day indicating the battery needs to be recharged, after 3 days battery bay light is off.

Is it a faulty battery?

Happy to purchase a new battery but don’t want to get it then find out it is the camera that has the issue not the battery.

Hey @senseiscott. At this time, if your Spotlight Camera will not reconnect or complete a setup with the batteries that you have, please attempt the following:

  • Ensure both of your batteries are fully charged (if you have two), or has been charging for several hours.
  • Ensure there is no debris in the battery hatch and that the hatch is closed.
  • Press the setup button on the Cam and complete the setup in the Ring app.
  • If lights flash and setup is not completing in the app, please remove and reinstall the Ring app on your mobile device, disable VPN, and have your wifi router close to your Camera (if possible). You can also see if you can set up the device on another Ring app on another phone you can log into.
  • If lights do not indicate setup mode on the Spotlight Cam, or setup is not completing, perform a reset on the Camera by holding the setup button for 20 seconds and try the setup again.

If the above steps do not result in successful setup or operation of the batteries, please give our support team a call at one of the numbers available here. They can verify if everything is ok with the device before you purchase a new battery. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Let me know how this goes!

Hi,

I am having the same issue. I actually have 2 of the battery ring spotlight cameras, and one is working and the other isn’t and has this issue. I know the battery is good because I tried putting it in the working camera and it registered as charged.

I tried holding the set up button for 20+ seconds and got nothing.

Have you found a solution to this?