Battery not charging (Doorbell 2), all event history lost

My ring doorbell won’t charge (Ring Doorbell 2, I use it on battery). On the app, for Battery Level it says “Add a Battery”. It’s been plugged in for about 24 hours and occasionally flashes blue but it is not charging. It’s connected to the wifi.

Also all of my event history has disappeared, my subscription is live, it automatically renewed a few days ago.

Bit of history, this is a replacement doorbell (received Sept '21) after the one I purchased malfunctioned. I live on a busy road and at first the battery lasted about a month before I needed to charge it. Since summer of last year I’ve had to charge it maybe every 5 to 6 days despite not changing any settings (I’m not sure if the heatwave we had in the UK affected the battery, it reached about 37 degrees where I live and the doorbell is by a south facing door). I have just returned from being away for a month and am not sure when the battery died but it had been dead for a least a few days by the time I got home (I had turned off most of the features to keep the battery going for more than 6 days).

Hi @Shinen. If your Doorbell is no longer taking a charge, try the following steps:

  • Use a different micro-USB cable to charge your Doorbell to see if that makes a difference.

  • Factory reset your Doorbell by pressing and holding the setup button for 20–25 seconds. It should flash a blue light for a few seconds, and once that is done, reconnect it to your wifi.

If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support. They will also be able to investigate the recordings that disappeared.

Thanks Justin. I had tried both those steps. I’ll call the help centre.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.