base station won't power on

i brought the new ring 2 gen 8 piece set today, and the base station will not power on… everthing else in the package works well. ive tried pluging it into several diffent outlets and pushing the rest button but nothing works. any suggestions?

Hey @rushing74. If the Base Station is not receiving any power or even booting up after being plugged in for awhile, it would be best to follow up with our support team on this.

Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

for anyone that has this problem in the future, try unplugging th battery for about 30 mins to a hour, then put the battery back in and plug it back up. worked for me

2 Likes

You saved me over an hour trip back to the store to return what I thought was a defective product. Thank you so very much!