Base Station setup wifi connection fails with hidden SSID

Couldn’t get my base station to connect to my wifi network setting up manually to a hidden SSID. It worked fine with the ethernet connection. Ring support tried to tell me that my wifi firewall was preventing it to connect. I tried to tell him that there is only one firewall. I tried rebooting the Xfinity router. Problem connecting to wifi with hidden SSID still.

I found the solution. Edit router settings to Broadcast SSID. Connect to wifi in base station setup now works. Then you can go back to router setup and stop broadcasting SSID again. Base station still connected to wifi.

2 Likes

@Hud wrote:

Couldn’t get my base station to connect to my wifi network setting up manually to a hidden SSID. It worked fine with the ethernet connection. Ring support tried to tell me that my wifi firewall was preventing it to connect. I tried to tell him that there is only one firewall. I tried rebooting the Xfinity router. Problem connecting to wifi with hidden SSID still.

I found the solution. Edit router settings to Broadcast SSID. Connect to wifi in base station setup now works. Then you can go back to router setup and stop broadcasting SSID again. Base station still connected to wifi.

Hi @Hud ,

Thanks for sharing that great and relatively easy solution on how to connect your Base Station to a “Hidden SSID.” :slight_smile:

It is good to know that there is a way, as you edited your router to broad the SSID to a ‘visible’ SSID, connect the Base Station, and then returned the SSID to ‘invisible’ again. Nice to know that once the Base Station has connected to that SSID that it stayed connected even when the router is returned back invisible/hidden.

It makes me wonder about something, so have a question for you. Do you know that if the router goes ‘offline’ (like if you temporarily unplug the router’s power) and after the router’s power is restored and it completes booting up, does the Base Station automatically reconnect to the hidden ‘invisible’ SSID ?

Logically, I think the Base Station would automatically reconnect to the ‘hidden’ SSID, but I’m wondering if you have already confirmed this?

:slight_smile: