Base Station Light Red, Unresponsive

I have a small business that uses the Ring security system. This morning when I opened my store, I noticed that the alarm was disarmed. The base station had a red light. It’s usually blue. When I tried to reconnect it using the app, it stated that it cannot connect, check internet connection, etc. The internet has been working strong all day - now at the end of the day, the alarm base station is still red. I tried resetting it but nothing happens. I tried paring but nothing happens. It’s stuck with the red light and won’t do anything.

I unplugged it from the wall, still a red light. I opened the battery compartment thinking I would remove the battery to try and reset it by turning it off/ on, but the battery seems to be permanently installed.

I tried contacting Ring Support, sat on hold for more than 30 minutes, and no one is answering. What to do?

Has anyone had these problems? It’s worked flawlessly for a year and now I can’t seem to get it to work.

The base station is the heart of the system. As stated by Ring, you shouldn’t reset it without speaking with customer service.
Here’s their statement.
" Factory Reset your Base Station:
Do not attempt to factory reset your Ring Alarm Base Station without guidance and support from a trained Ring Customer Support expert. Please contact Customer Support for assistance if you’re having difficulty with your Ring Alarm."

Thanks for the update and quick reply. I’ll be sure to keep an eye on this thread. I am also encountering this issue. Dont know why its hapenning.