Backwards Address using MS Edge

When I get a Ring alert on my computer and click on it, I get “Hmmm… can’t reach this page”. When I look at the address in the bar on the MS Edge browser I see, http://0%7C0%7Cdefault%7C0%7Chttps//account.ring.com/%7Cp#Home Security Systems | Smart Home Automation | Ring which it is not correct. It happens on every alert I click on. I done all I know to do even as far as uninstalling Edge and reinstalling so how can I fix it?

I did not notice any Ring settings inside the MS Edge browser settings, but did go to Windows Settings, notifications and turned everything off. Went to ring.com and did the push notification button. Same old stuff still will not show up except can’t find the page and the address looks all messed up.

Hi @Bluesooner17. Do you have any ad blocker or anti virus programs? Do you have a VPN in use? Have we tried other web browsers on the same computer if available? Or tried MS Edge on another computer? Have you also tried clearing cache/cookies? What happens if you try this on an incognito tab? You can do so by selecting and holding (right-click) a link and select Open link in InPrivate window. This extra information will help me figure out what other troubleshooting steps I would recommend. :slightly_smiling_face: