Autoplay stopped working when viewing history on a PC

I have two hardwired security cams (1 Floodlight, 1 Spotlight) and review the history on both my Iphone and my PC. Viewing history on the Iphone has not changed, but it has on the PC so my comments here only apply to the PC. I typically review history by clicking on the history tab. On that page, there is an itemized list of videos on the left and video review screen on the right. The List side works the same as always. On the video review screen, there are 3 buttons. Back, Play/Pause and Forward.

And now, here’s my problem… Up until just a few days ago when I clicked the forward button, the video would default to “Play”. Now, it defaults to “Pause”. To watch each successive video, I have to click forward and then play. Seems like a minor problem, but it’s a real pain to have to click play with each new event. Did I inadvertantly change something in the settings or is this something that Ring programmers did? Is there a way to turn the autoplay back on?

1 Like

You are not alone. I am facing the same issue. I also noticed that you can no longer right click on the video to bring up the controls in full screen mode. I am sure your settings are what they were 2 days ago. I also did not change anything about my settings and I cannot go backwards or forwards through the video(s) without having to hit play on each one. This is a great annoyance. I am sure this was a change on the Ring Side put in place by their SR Leadership team who have never used this feature ever. I do not blame devs ever as they are doing what they are told to do. I blame SR Leadership who have very little knowledge of the product they are supposed to know and support.

1 Like

Hi neighbors. Thank you for sharing this information. I will reach out to my team to have this looked at, and I will provide an update once I have more information.

Count me as another user looking for return of the autoplay function.

Just another reason to dislike Ring. App sucks (too many steps to get to light controls) and now it’s time-consuming to check videos on the website. Bring back autoplay.

Thanks Justin! Looks like the autoplay feature is working again… Now, if you could just get rid of the doorbell camera ad on my dashboard, I’d greatly appreciate it!

Hi @wam1, I’m glad to hear the autoplay feature is working as intended again. Thank you for sharing your feedback!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.